Bug 55261 - TestSwallowAbortedUploads fails
TestSwallowAbortedUploads fails
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Connectors
trunk
Macintosh other
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-07-14 00:20 UTC by Jeremy Boynes
Modified: 2013-07-30 08:17 UTC (History)
0 users



Attachments
log from BIO run (10.24 KB, text/plain)
2013-07-14 00:22 UTC, Jeremy Boynes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Boynes 2013-07-14 00:20:20 UTC
With a fresh checkout of 7.0.x I am seeing failures with TestSwallowAbortedUploads under both BIO and NIO. Are there issues with this test case? 

Macintosh OS X 10.8.4

java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

The same test passes with trunk using Java7.
Comment 1 Jeremy Boynes 2013-07-14 00:22:27 UTC
Created attachment 30589 [details]
log from BIO run
Comment 2 Rainer Jung 2013-07-14 03:30:08 UTC
(In reply to Jeremy Boynes from comment #0)
> With a fresh checkout of 7.0.x I am seeing failures with
> TestSwallowAbortedUploads under both BIO and NIO. Are there issues with this
> test case? 
> 
> Macintosh OS X 10.8.4
> 
> java version "1.6.0_51"

> The same test passes with trunk using Java7.

Works on Solaris with 1.6.0_45.
Comment 3 Violeta Georgieva 2013-07-14 07:07:26 UTC
(In reply to Jeremy Boynes from comment #0)
> Macintosh OS X 10.8.4
> 
> java version "1.6.0_51"
> Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
> Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

Mac OS X 10.7.5

java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-456-11M4508)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-456, mixed mode)

Tests are executed successfully.
Comment 4 Mark Thomas 2013-07-14 08:31:47 UTC
Works on Windows Server 2008 R2, Unbuntu 12.04.02 LTS (64-bit) and Ubuntu 10.04.3 LTS (buildbot CI system).

I do see the same problem with OSX 10.8.4 and Java 1.6.0_51. At the moment this looks like an OSX specific issue with Java 6 but it is worth digging into to see if there is a problem with the test.
Comment 5 Mark Thomas 2013-07-30 08:17:13 UTC
Some debugging and svn archaeology identified that this is caused by OSX buffering more data than the test expects. The request fails, just not as expected.

This was already fixed in trunk so I backported the same fix to 7.0.x. It will be included in 7.0.43 onwards.