Bug 56208 - validateXml attribute is missing in jasper Ant Task (JspC) in 6.0.39, 7.0.52
validateXml attribute is missing in jasper Ant Task (JspC) in 6.0.39, 7.0.52
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Jasper
6.0.39
All All
: P2 regression (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-03-03 12:12 UTC by Konstantin Kolinko
Modified: 2014-03-19 15:04 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kolinko 2014-03-03 12:12:19 UTC
Mail threads:

http://tomcat.markmail.org/thread/4gblbbzxltq5jpzw
http://tomcat.markmail.org/thread/ydrqotnjkmdl6err
http://tomcat.markmail.org/thread/sn5gkulktf7tteon

This has already been fixed in Tomcat 7 by r1570163 and will be in 7.0.53.

Note that starting with 7.0.53 "validateXml" and "validateTld" are two distinct options.

As of now "validateXml" option is removed from Tomcat 8 since 8.0.3 onwards. Some pending cleanup and discussion on whether to reimplement in Tomcat 8 is tracked as bug 56199.


If you are using validateXml="false", my recommendation is to just remove that attribute from your build files. (It does not serve anything, as "false" is the default value for this attribute).


A backport of r1570163 has been proposed for 6.0
Comment 1 Mark Thomas 2014-03-19 15:04:47 UTC
This has been fixed in 6.0.x and will be included 6.0.40.