Bug 56543 - Jasper fails to compile JSP pages when running with JDK 1.8
Jasper fails to compile JSP pages when running with JDK 1.8
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Jasper
7.0.53
PC All
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-05-19 10:25 UTC by Robbie Gibson
Modified: 2014-06-25 18:16 UTC (History)
0 users



Attachments
Failing minimal webapp (10.00 KB, application/x-tar)
2014-05-19 10:25 UTC, Robbie Gibson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robbie Gibson 2014-05-19 10:25:12 UTC
Created attachment 31636 [details]
Failing minimal webapp

Taking an existing Tomcat/webapp installation and running with JDK 1.8 leads to compile errors with Jasper.

It seems due to Eclipse defect 390889  https://bugs.eclipse.org/bugs/show_bug.cgi?id=390889

Attached is a reduced webapp which works fine when run with JDK 1.6 or 1.7 but fails with 1.8.

(First reported at https://issues.apache.org/bugzilla/show_bug.cgi?id=56283)
Comment 1 Robbie Gibson 2014-05-19 10:26:26 UTC
Replacing ecj-P20140317-1600.jar with ecj-4.4M7.jar from http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops4/S-4.4M7-201405010200/ecj-4.4M7.jar seems to fix the problem.
Comment 2 Violeta Georgieva 2014-05-19 11:06:13 UTC
ECJ 4.4RC1 is available.
Should we wait for the official release? (which will happen end of June with Luna release)
Comment 3 Mark Thomas 2014-05-19 11:08:18 UTC
I'd be concerned about regressions using an ECJ RC in a stable Tomcat version. Upgrading ECJ is as simple as replacing the JAR so users impacted by this bug have a simple fix available.
Comment 4 Remy Maucherat 2014-05-19 21:09:18 UTC
It would be a good plan to upgrade 8 asap, however, even if the JDT build is a bit "new".
Comment 5 Mark Thomas 2014-05-20 12:32:45 UTC
I've updated 8.0.x to 4.4RC1 which will be included in 8.0.9 onwards.
Comment 6 Konstantin Kolinko 2014-05-21 12:31:01 UTC
(In reply to Mark Thomas from comment #5)
> I've updated 8.0.x to 4.4RC1 which will be included in 8.0.9 onwards.

r1596227 + r1596227

The official release of Eclipse 4.4 is expected in a month - on June 25, 2014 ("Luna") [1]

[1] http://projects.eclipse.org/releases
Comment 7 Mark Thomas 2014-06-16 10:29:42 UTC
I've updated 8.0.x to 4.4 RC4.
Comment 8 Violeta Georgieva 2014-06-25 18:16:39 UTC
JDT has been updated to version 4.4 in trunk for 8.0.10 and in 7.0.x for 7.0.55 onwards.