Bug 56990 - ant ide-eclipse target shall download easymock library
ant ide-eclipse target shall download easymock library
Status: RESOLVED FIXED
Product: Tomcat 8
Classification: Unclassified
Component: Meta
8.0.12
PC All
: P2 normal (vote)
: ----
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-09-17 22:31 UTC by Konstantin Kolinko
Modified: 2014-09-24 06:46 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kolinko 2014-09-17 22:31:03 UTC
When configuring Eclipse project for Tomcat 8 via "ant ide-eclipse" command, as documented at [1], it does not download easymock library. The library is referenced in res/ide-support/eclipse/eclipse.classpath file.

[1] http://tomcat.apache.org/tomcat-8.0-doc/building.html

This issue was originally reported via documentation comments system at [1].

The "ide-eclipse" target downloads libraries used by build and by extras, but it does not download libraries used by test target.
Comment 1 Mark Thomas 2014-09-22 14:01:31 UTC
Fixed in 8.0.x for 8.0.13 onwards.
Comment 2 Konstantin Kolinko 2014-09-24 06:46:53 UTC
Thank you. I ported the fix to Tomcat 7 in r1627231, it will be in 7.0.56.

Tomcat 7 tests do not use easymock, but users say that they want to use the same version of junit and hamcrest libraries as used by Tomcat instead of ones provided by IDE, as the latter ones may be outdated. This change makes `ant ide-eclipse` target to download those libraries.