Bug 57079 - Use Tomcat version number in jdbc-pool manifest when building it as part of Tomcat
Use Tomcat version number in jdbc-pool manifest when building it as part of T...
Status: RESOLVED FIXED
Product: Tomcat 8
Classification: Unclassified
Component: Packaging
8.0.14
PC All
: P2 normal (vote)
: ----
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-10-13 13:10 UTC by Konstantin Kolinko
Modified: 2014-10-21 22:52 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kolinko 2014-10-13 13:10:32 UTC
Looking into tomcat-jdbc.jar/META-INF/MANIFEST.MF file,

Actual behaviour:
currently (e.g. for 8.0.14) it contains:
[[[
Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.0
Created-By: 11.0-b16 (Sun Microsystems Inc.)
Export-Package: org.apache.tomcat.jdbc.naming;uses:="javax.naming,org.
 apache.juli.logging,javax.naming.spi";version="1.1.0.1",org.apache.to
 mcat.jdbc.pool;uses:="org.apache.juli.logging,javax.sql,org.apache.to
 mcat.jdbc.pool.jmx,javax.management,javax.naming,javax.naming.spi,org
 .apache.tomcat.jdbc.pool.interceptor";version="1.1.0.1",org.apache.to
 mcat.jdbc.pool.interceptor;uses:="org.apache.tomcat.jdbc.pool,org.apa
 che.juli.logging,javax.management.openmbean,javax.management";version
 ="1.1.0.1",org.apache.tomcat.jdbc.pool.jmx;uses:="org.apache.tomcat.j
 dbc.pool,org.apache.juli.logging,javax.management";version="1.1.0.1"
Bundle-Vendor: Apache Software Foundation
Bundle-Version: 1.1.0.1
Bundle-Name: Apache Tomcat JDBC Connection Pool
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.apache.tomcat.jdbc
Import-Package:  javax.management;version="0", javax.management.openmb
 ean;version="0", javax.naming;version="0", javax.naming.spi;version="
 0", javax.sql;version="0", org.apache.juli.logging;version="0"
]]]

It is generated from template in modules/jdbc-pool/resources/MANIFEST.MF 

Expected behaviour:
1) I expected "Ant-Version: Apache Ant 1.8.4", because that was the version of Ant used to build Tomcat 8.0.14.
"Ant-Version: Apache Ant 1.7.0" is hard-coded in template file.

2) "Bundle-Version: 1.1.0.1" and versions in "Export-Package" to be 8.0.14.
The goal is to discern different builds of JDBC Pool.
I guess it boils down to passing relevant ${version} property when invoking its build file from Tomcat one.

Can we change that "1.1.0.1" to be "8.0.14", or there will be any problems?

As this issue involves OSGi, a better reference would be bug 52381.
Comment 1 Mark Thomas 2014-10-16 19:47:19 UTC
Fixed in 8.0.x for 8.0.15 onwards.

Using the Tomcat version number makes sense to me when shipping as part of Tomcat.

Since the version numbers are not over-lapping, this shouldn't cause any problems.
Comment 2 Konstantin Kolinko 2014-10-21 22:52:50 UTC
Backported to Tomcat 7 in r1633478 and will be in 7.0.57 onwards.