Bug 57123 - Update to Eclipse ECJ 4.4.1
Update to Eclipse ECJ 4.4.1
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Jasper
trunk
PC All
: P2 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2014-10-21 17:27 UTC by Konstantin Kolinko
Modified: 2015-03-04 12:06 UTC (History)
0 users



Attachments
2014-10-21_tc8_57123_ecj441.patch (4.25 KB, patch)
2014-10-21 17:51 UTC, Konstantin Kolinko
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kolinko 2014-10-21 17:27:25 UTC
Eclipse 4.4.1 has been released. It is possible to update ECJ compiler from current version 4.4 to 4.4.1.

Download page:
http://download.eclipse.org/eclipse/downloads/drops4/R-4.4.1-201409250400/
-> "JDT Core Batch Compiler"

(There have been a report about JSP compilation issue (crash) with the ECJ 4.4. Unfortunately, updating to ecj-4.4.1 nor to a nightly does not fix that particial issue. I filed a bug report upstream to Eclipse project:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=448112
Thread at tomcat-users mailing list:
http://tomcat.markmail.org/thread/jblxumvub6o7nusr
)

(A warning: Regarding Eclipse IDE itself I would recommend against using version 4.4.1 aka Luna SR1 as a development environment, because of known regression that broke many components of the IDE,
https://bugs.eclipse.org/bugs/show_bug.cgi?id=445122#c7

This does not concern the ECJ compiler.
)
Comment 1 Konstantin Kolinko 2014-10-21 17:51:49 UTC
Created attachment 32133 [details]
2014-10-21_tc8_57123_ecj441.patch

Patch to update Tomcat 8 (trunk) to ECJ 4.4.1
Comment 2 Konstantin Kolinko 2014-10-21 18:10:01 UTC
Tomcat 8:
- smoke testing: OK
- testsuite (Nio connector): OK

Thus ecj-4.4.1 can be used.

A pending question is update of jasper poms, as ecj-4.4.1.jar is not yet available from Maven Central.
https://wiki.apache.org/tomcat/JDTCoreBatchCompiler
Comment 3 Mark Thomas 2015-02-02 22:11:08 UTC
9.0.x and 8.0.x (8.0.19 onwards) updated.

Moving to 7.0.x.
Comment 4 Violeta Georgieva 2015-03-04 09:11:59 UTC
(In reply to Konstantin Kolinko from comment #0)
> (There have been a report about JSP compilation issue (crash) with the ECJ
> 4.4. Unfortunately, updating to ecj-4.4.1 nor to a nightly does not fix that
> particial issue. I filed a bug report upstream to Eclipse project:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=448112

ecj-4.4.2 is out there and the compilation issue does not exist anymore.
So may be we can update trunk

> Thread at tomcat-users mailing list:
> http://tomcat.markmail.org/thread/jblxumvub6o7nusr
> )


Regards,
Violeta
Comment 5 Konstantin Kolinko 2015-03-04 11:29:00 UTC
(In reply to Violeta Georgieva from comment #4)

I filed bug 57662 for Tomcat 8 to track update to 4.4.2.


This issue (ECJ 4.4.1) waits for a backport to Tomcat 7.
Comment 6 Mark Thomas 2015-03-04 12:06:41 UTC
Fixed in 7.0.x for 7.0.60 onwards.