Bug 57656 - __regexFunction doesn't works in remote testing with MODE_STRIPPED_BATCH
Summary: __regexFunction doesn't works in remote testing with MODE_STRIPPED_BATCH
Status: RESOLVED DUPLICATE of bug 56376
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.12
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-03 09:34 UTC by bernd.lemmer@wincor-nixdorf.com
Modified: 2015-03-03 20:42 UTC (History)
1 user (show)



Attachments
Testplan for reproducing the problem. (1.69 KB, application/zip)
2015-03-03 09:34 UTC, bernd.lemmer@wincor-nixdorf.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bernd.lemmer@wincor-nixdorf.com 2015-03-03 09:34:46 UTC
Created attachment 32542 [details]
Testplan for reproducing the problem.

__regexFunction() is a very fine and compact way to test the response data of the previous request in an "if" or "while" element without the need of setting an initial value or adding an regexp extractor. 
It works well under these precondition: local testing or remote testing and no stripping batch mode.
With the same testplan it don't works if it is remote tested an the default " MODE_STRIPPED_BATCH" is enabled.
If the remote batching configuration is switched to "mode=Standard", it works well again also remote.
Comment 1 Philippe Mouawad 2015-03-03 20:42:17 UTC

*** This bug has been marked as a duplicate of bug 56376 ***