Bug 58508 - role_name in tomcat-users.xml : invalid character
role_name in tomcat-users.xml : invalid character
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
6.0.44
PC All
: P2 major (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2015-10-20 09:22 UTC by Fred 33
Modified: 2015-11-03 09:30 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 33 2015-10-20 09:22:49 UTC
Bonjour, 

My tomcat server send exception about invalid characters with a role name "ubx:5485" ;

My first question is : why ? ;o)

and I would like find specifications about valid characters for a role name.

do you have some solution , because I used Ldap connection, and all my groups are this format "xx:yyy:zzz" .

Thanks a lot , 
Frederic (de Bordeaux : soleil et froid )
Comment 1 Mark Thomas 2015-10-24 15:07:46 UTC
Thanks for the report. The problem was the generation of the associated MBean. This has been fixed for trunk, 8.0.x (for 8.0.29) and 7.0.x (for 7.0.66). It has been proposed for 6.0.x.
Comment 2 Mark Thomas 2015-10-28 01:22:17 UTC
Restore correct version.
Comment 3 Fred 33 2015-10-28 08:08:09 UTC
Bonjour, 

the version of my tomcat server is 7.057 , and not 6.x

Regards 
Frederic
Comment 4 Violeta Georgieva 2015-10-28 08:44:58 UTC
Hello,

The issue is fixed for Tomcat 7 and Tomcat 8.
We moved the issue to Tomcat 6 and proposed a fix there, because of this the version now is Tomcat 6.

Regards,
Violeta
Comment 5 Mark Thomas 2015-11-03 09:30:52 UTC
Fixed in 6.0.x for 6.0.45 onwards.