Bug 58983 - If Controller does not work properly when Transaction Controller generates parent sample
Summary: If Controller does not work properly when Transaction Controller generates pa...
Status: RESOLVED DUPLICATE of bug 59067
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-09 14:21 UTC by onlinehenk
Modified: 2016-02-26 21:18 UTC (History)
1 user (show)



Attachments
JMeter testplan with example of the bug and example of the workaround. (12.80 KB, application/xml)
2016-02-09 14:21 UTC, onlinehenk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description onlinehenk 2016-02-09 14:21:06 UTC
Created attachment 33535 [details]
JMeter testplan with example of the bug and example of the workaround.

When you want to use the If Controller when your variable == 'something', this does not work after 'Start next Thread loop'. 

Situation:
${VariableForIf} = IfIsYes

If controller condition: "${VariableForIf}" == "IfIsYes"
In the If controller there is a assertion: When "${VariableForIf}" == "IfIsYes" the assertion will fail.
Then 'Start next thread loop' is applicable.
Second time the If controller is not touched.

Expected situation:
As long as ${VariableForIf}" == "IfIsYes" the flow is going into the If controller, the assertion will fail, and again and again.

Work arround: check out 'generate parent sample' of the Transaction Controller.

See attachment for an example.
Comment 1 Philippe Mouawad 2016-02-26 21:17:33 UTC

*** This bug has been marked as a duplicate of bug 59067 ***