Bug 59368 - addColumnLabel is wrong method name
Summary: addColumnLabel is wrong method name
Status: RESOLVED DUPLICATE of bug 59705
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.15-dev
Hardware: PC All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Reported: 2016-04-22 16:37 UTC by Gabriel Jones
Modified: 2016-06-17 10:50 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Jones 2016-04-22 16:37:15 UTC
XSSFPivotTable.addDataColumn should be called addColumnLabel
XSSFPivotTable.addColumnLabel should be called addValue

As it stands these method names are out of harmony with the Excel GUI for manipulating dimensions in a Pivot Table.  The proposed method renaming would bring the GUI and the api into harmony.

Much confusion is to be had under the current naming scheme.
Comment 1 Javen O'Neal 2016-06-17 10:50:52 UTC

*** This bug has been marked as a duplicate of bug 59705 ***