Bug 60118 - Cannot assign Samba/CIFS subtree as docroot: "DocumentRoot must be a directory"
Summary: Cannot assign Samba/CIFS subtree as docroot: "DocumentRoot must be a directory"
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.4.23
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
Depends on:
Reported: 2016-09-12 12:54 UTC by MMacD
Modified: 2016-09-12 12:54 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description MMacD 2016-09-12 12:54:43 UTC
My server-of-all-work runs FreeBSD 10.2, with Samba 4.3 providing service to 1 W7 and 2 XP clients.  They are all on a lan protected by a pfSense firewall.

Installing Apache 2.4.23 on (this) W7 box for dev purposes, I tried to assign a subtree on the server as docroot so that the server can play the role of webserver and I don't have to have source files in multiple locations.  

The subtree is readily accessible via Samba to editors, shells, and the "explorer" filesystem front end under XP and W7, and also to 2 other FreeBSD boxes over NFS.  

But I cannot start the httpd service with that docroot assignment; it complains that docroot must be a directory.  I successively tried Windows drive-letter mapping (M:), the underlying literal path with Windows syntax (\\server\pages) and Unix (//server/pages), and the absolute path (//  Same error each time.  I tried creating an account on this machine that mirrors the Samba account and entered that as a login account for the httpd service.  No joy.

The service starts and runs fine with a machine-local docroot.