Bug 60643 - HTTP(S) Test Script Recorder doesn't correctly handle restart or start after stop
Summary: HTTP(S) Test Script Recorder doesn't correctly handle restart or start after ...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.10
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2017-01-25 14:34 UTC by UbikLoadPack support
Modified: 2017-01-25 17:02 UTC (History)
1 user (show)



Attachments
Patch fixing the issue (2.94 KB, patch)
2017-01-25 14:37 UTC, UbikLoadPack support
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2017-01-25 14:34:51 UTC
Hello,
There is a really annoying bug that exists since many versions.

To reproduce:
- Create a Recording template
- Start the recorder 
- Navigate
- Recording is saved to recording.xml
- Stop or restart recording or change file

- Navigate => From now on nothing is saved to recording.xml


You have to restart JMeter to record again.

This Makes user loose their recording frequently whenever they restart or start/stop after changing (or not) the output file.
Comment 1 UbikLoadPack support 2017-01-25 14:37:37 UTC
Created attachment 34674 [details]
Patch fixing the issue

The fix is contained in finalizeFileOutput() where out is set to null.

We've reorganized a bit the file to fix Sonar warnings.
Comment 2 Philippe Mouawad 2017-01-25 17:02:05 UTC
Author: pmouawad
Date: Wed Jan 25 17:01:30 2017
New Revision: 1780239

URL: http://svn.apache.org/viewvc?rev=1780239&view=rev
Log:
Bug 60643 - HTTP(S) Test Script Recorder doesn't correctly handle restart or start after stop
Bugzilla Id: 60643

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/reporters/ResultCollector.java
    jmeter/trunk/xdocs/changes.xml

Contributed by UbikLoadPack.