Bug 60941 - Content-Type is added forcibly by HttpClient4 for GET requests with no arguments
Summary: Content-Type is added forcibly by HttpClient4 for GET requests with no arguments
Status: RESOLVED DUPLICATE of bug 60575
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.1
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-30 13:42 UTC by Valentine Petrovsky
Modified: 2017-03-31 09:56 UTC (History)
0 users



Attachments
A sampler example (3.83 KB, application/xml)
2017-03-30 13:42 UTC, Valentine Petrovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valentine Petrovsky 2017-03-30 13:42:23 UTC
Created attachment 34890 [details]
A sampler example

Using HttpClient4 implementation for GET-requests with no arguments adds Content-Type and Content-Length headers unconditionally:
Content-Length: 0
Content-Type: text/plain; charset=UTF-8

Initially a sampler has 'Accept: application/json, text/plain, */*' header, as was captured from browser traffic by HTTP Proxy Server component.

Adding the 'Content-Type' header causes 415 HTTP error for our web-application. There is no error for 3.0 JMeter version and earlier.
Comment 1 UbikLoadPack support 2017-03-30 13:44:19 UTC

*** This bug has been marked as a duplicate of bug 60575 ***
Comment 2 UbikLoadPack support 2017-03-30 13:48:24 UTC
Hello,
Issue is fixed in nightly build which is close to release.
You can try it and give us feedback.
Thanks
@ubikloadpack
Comment 3 Valentine Petrovsky 2017-03-31 09:56:52 UTC
(In reply to UbikLoadPack support from comment #2)
> Hello,
> Issue is fixed in nightly build which is close to release.
> You can try it and give us feedback.
> Thanks
> @ubikloadpack

Tested on r1789608 build. It's OK.

Thanks