Bug 61127 - Allow cluster channelSendOptions to be specified with verbose, human-readable names
Summary: Allow cluster channelSendOptions to be specified with verbose, human-readable...
Status: RESOLVED FIXED
Alias: None
Product: Tomcat 9
Classification: Unclassified
Component: Catalina (show other bugs)
Version: unspecified
Hardware: All All
: P2 enhancement (vote)
Target Milestone: -----
Assignee: Tomcat Developers Mailing List
URL:
Keywords: Beginner
: 61128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-26 20:44 UTC by Christopher Schultz
Modified: 2017-06-21 19:43 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Schultz 2017-05-26 20:44:26 UTC
Cluster channels support "channelSendOptions" which is specified as an integer value, bitwise-ORd from the individual bits which make-up the various options.

The default value is 8 for the DeltaManager which means "asynchronous".

It would be nice if the configuration could use human-readable options like "async" instead of "8".

These are the channel send options available:

SEND_OPTIONS_ASYNCHRONOUS
SEND_OPTIONS_BYTE_MESSAGE
SEND_OPTIONS_MULTICAST
SEND_OPTIONS_SECURE
SEND_OPTIONS_SYNCHRONIZED_ACK
SEND_OPTIONS_UDP
SEND_OPTIONS_USE_ACK

They could be specified as human-readable strings e.g. channelSendOptions="async,multicast" instead of channelSendOptions="72" which would make the configuration much easier to both read and write.

For backward compatibility, the integer values should also be acceptable.
Comment 1 Igal Sapir 2017-05-28 22:35:56 UTC
Please see https://github.com/apache/tomcat/pull/56 as a WIP.

Especially given the fact that this is my first PR I would need more feedback.
Comment 2 Christopher Schultz 2017-06-21 19:39:54 UTC
*** Bug 61128 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Schultz 2017-06-21 19:43:26 UTC
Fixed in r1799462, r1799464, and r1799466 (the latter being cleanup for an inadvertently-committed change to the build script). Will be in Tomcat 9.0.0.M23 and later.

Back-ports likely forthcoming to Tomcat 8.5.x and Tomcat 8.0.x.