Bug 61261 - __XPath function returns null despite xpath checker founds matches
Summary: __XPath function returns null despite xpath checker founds matches
Status: RESOLVED DUPLICATE of bug 61260
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.2
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-07 07:09 UTC by Alex
Modified: 2017-07-07 08:01 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2017-07-07 07:09:29 UTC
Step to reproduce:

1)note.xml content:

<?xml version="1.0" encoding="UTF-8"?>
<note>
  <to>Tove</to>
  <from>Jani</from>
  <heading>Reminder</heading>
  <body>Don't forget me this weekend!</body>
</note>

2)XPath function expression:

${__XPath(d:\\test\\note.xml,note/body)}
${__XPath(d:\test\note.xml,note/body)}
${__XPath(d:/test/note.xml,note/body)}
All of  the variants don't work

Actual result:
Function returns: null

Expected result:
Function returns: Don't forget me this weekend!
Comment 1 Alex 2017-07-07 08:01:03 UTC

*** This bug has been marked as a duplicate of bug 61260 ***