Bug 61378 - JMETER -creating large number of TCP connections while testing JMS application
Summary: JMETER -creating large number of TCP connections while testing JMS application
Status: RESOLVED DUPLICATE of bug 53833
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.1
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-03 20:22 UTC by phani.9284
Modified: 2018-09-05 15:37 UTC (History)
1 user (show)



Attachments
Test plan (237.85 KB, image/png)
2017-08-10 18:01 UTC, phani.9284
Details

Note You need to log in before you can comment on or make changes to this bug.
Description phani.9284 2017-08-03 20:22:24 UTC
While testing the TIBCO application using JMS Publisher. Jmeter is creating large number of TCP connections and is effecting the performance of the application. Below is our scenario

I have 40  different messages to test in TIBCO and will be posting these messages into 10 different queues with varied TPS. In order to test , I have created a thread group under the test plan and have added 40 JMS Publisher samplers to the threadgroup . ideally in this scenario if I run with 1 thread , there should only be one tcp connection since I am going sequentially one of after the sampler. However Jmeter is creating 3 connections for every sample and closing 2 connections and keeping 1 connection open till the end of iteration . 

Since we have 40 samples to go through it will create 40 connections per 1 thread per 1 iteration and as during the load test we will run with more threads we will end up in creating large number of tcp connections . 

In real world, Connections are fixed and will be reused where as in this case new connection is established every time.


Request you to provide solution for this issue and appreciate you for your time and effort.
Comment 1 Felix Schumacher 2017-08-05 15:19:41 UTC
Can you give a sample test plan, that exhibits the described behaviour? Especially have a look at the setting of "Setup". Is "At startup" selected?
Comment 2 phani.9284 2017-08-10 18:01:12 UTC
Created attachment 35211 [details]
Test plan
Comment 3 phani.9284 2017-08-10 18:03:55 UTC
Thank you very much for getting back to me Felix, Please find the attached screenshot of the Test plan , I have graded the names and queue details. We have 40 events for which we have push the messages to the queues. We are using 40 JMS Publisher samplers in the script and will be executed in sequence.
Comment 4 phani.9284 2017-08-10 18:04:55 UTC
(In reply to Felix Schumacher from comment #1)
> Can you give a sample test plan, that exhibits the described behaviour?
> Especially have a look at the setting of "Setup". Is "At startup" selected?

Hi Felix , 

Thank you very much for getting back to me Felix, Please find the attached screenshot of the Test plan , I have graded the names and queue details. We have 40 events for which we have push the messages to the queues. We are using 40 JMS Publisher samplers in the script and will be executed in sequence.
Comment 5 Philippe Mouawad 2017-08-27 13:05:15 UTC

*** This bug has been marked as a duplicate of bug 53833 ***
Comment 6 Andy Macdonald 2018-05-29 00:58:09 UTC
Has this issue been resolved? If so, which version was it part of? I cannot see it in any Jmeter release notes and have encountered the same issue.
Comment 7 Philippe Mouawad 2018-09-05 15:37:05 UTC
(In reply to Andy Macdonald from comment #6)
> Has this issue been resolved? If so, which version was it part of? I cannot
> see it in any Jmeter release notes and have encountered the same issue.

No it has not, please follow Bug 53833 (since your issue is a duplicate of it)