Bug 63055 - View Results Tree - Error naming sub controllers under Transaction Controllers when it's manually loaded .jtl file
Summary: View Results Tree - Error naming sub controllers under Transaction Controller...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.0
Hardware: All All
: P1 major (vote)
Target Milestone: JMETER_5.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 62887 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-03 15:47 UTC by JoaoEnes
Modified: 2019-02-07 11:53 UTC (History)
4 users (show)



Attachments
PrintScreen (58.26 KB, image/png)
2019-01-03 15:47 UTC, JoaoEnes
Details
jtl (3.26 KB, application/xml)
2019-01-03 15:48 UTC, JoaoEnes
Details
Test Plan.jmx (6.05 KB, application/xml)
2019-01-03 15:49 UTC, JoaoEnes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JoaoEnes 2019-01-03 15:47:16 UTC
Created attachment 36361 [details]
PrintScreen

after open an existent .jtl file with View Results Tree was verified:
 - Error, the controllers under Transaction controller was bad named as "Transaction controller-0","Transaction controller-1" and so far, naming incremented instead of controllers name.

 Notes:
  - It not occur on run-time View Results Tree display, but when it is open the already existent .jtl file
  - On JMeter V4, this don't occur it render correctly the controllers names


on printscreen was showed the display with run-time View Results Tree display and then with the error when is done the load of created .jtl file
Comment 1 JoaoEnes 2019-01-03 15:48:13 UTC
Created attachment 36362 [details]
jtl
Comment 2 JoaoEnes 2019-01-03 15:49:19 UTC
Created attachment 36363 [details]
Test Plan.jmx
Comment 3 Philippe Mouawad 2019-01-03 15:55:59 UTC
Hello,
Since JMeter 5.0, JMeter renames subResults to parentName-N where N is a number to ensure that Hits Per Second graph includes resources downloads.

See:

- Bug 62550
- Bug 62470
- Bug 60917

Regards
Comment 4 JoaoEnes 2019-01-03 17:56:48 UTC
Hi
thanks for your feedback!

So, for those that are using JMeter for "Functional Tests", there is any work around to get subresults names correctly?
Comment 5 a3v 2019-02-04 12:04:18 UTC
Hi,

We are in the same situation where we are using JMeter for functional tests.
Is there any workaround that will display the correct names inside the transaction controller?

Thanks
Comment 6 Philippe Mouawad 2019-02-04 12:36:01 UTC
(In reply to a3v from comment #5)
> Hi,
> 
> We are in the same situation where we are using JMeter for functional tests.
> Is there any workaround that will display the correct names inside the
> transaction controller?
> 
> Thanks

Hello JoaoEnes, a3v@qad.com,

When you use JMeter for functional testing, do you check the option on Test Plan elements ?

I am asking this question to see if we could include the old behaviour within this option.

Thanks for your feedback.
Comment 7 Artem Fedorov 2019-02-04 15:27:27 UTC
PR with fix https://github.com/apache/jmeter/pull/439
Comment 8 Philippe Mouawad 2019-02-04 20:20:25 UTC
Author: pmouawad
Date: Mon Feb  4 20:19:53 2019
New Revision: 1852943

URL: http://svn.apache.org/viewvc?rev=1852943&view=rev
Log:
Bug 63055 Don't rename SampleResult Label when test is running in Functional mode or property subresults.disable_renaming=true.

Implemented by Artem Fedorov (artem.fedorov at blazemeter.com) and contributed by BlazeMeter.

This closes #439
Bugzilla Id: 63055

Modified:
    jmeter/trunk/bin/jmeter.properties
    jmeter/trunk/src/core/org/apache/jmeter/samplers/SampleResult.java
    jmeter/trunk/test/src/org/apache/jmeter/samplers/TestSampleResult.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/properties_reference.xml
Comment 9 Philippe Mouawad 2019-02-04 20:22:59 UTC
Can you test "Last Jenkins build" in few minutes or nightly build tomorrow
http://jmeter.apache.org/nightly.html

or 

Please provide feedback on this so that we're able to release it in 5.1

Thanks
Comment 10 Philippe Mouawad 2019-02-04 20:25:49 UTC
*** Bug 62887 has been marked as a duplicate of this bug. ***
Comment 11 Philippe Mouawad 2019-02-06 19:38:14 UTC
(In reply to Philippe Mouawad from comment #10)
> *** Bug 62887 has been marked as a duplicate of this bug. ***

Any feedback please?

Thanks
Comment 12 Philippe Mouawad 2019-02-07 11:53:29 UTC
I am closing issue as resolved.

It would be nice if reporters  could test setting property:
subresults.disable_renaming=true

or checking use Functional mode 


PS : When volunteers spend time working on issues with big reactivity, my feeling is that the minimum would be to get feedback rapidly. But that's life I guess ...