Bug 64538 - not serving given IP number
Summary: not serving given IP number
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.4.43
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
Depends on:
Reported: 2020-06-19 11:18 UTC by uhlik
Modified: 2020-06-28 06:08 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description uhlik 2020-06-19 11:18:49 UTC
after upgrading to 2.4.43 httpd stopped serving requests given IP number rather than domain name
Comment 1 Christophe JAILLET 2020-06-19 16:08:53 UTC
This is a really surprising and unlikely behavior.

At least you should provide some additional information (configuration, log file, ...)

With just your description, we can hardly do anything.
Comment 2 uhlik 2020-06-22 06:46:39 UTC
I did nothing else but upgraded to newer version of httpd. All configuration remained the same and worked before. The configuration has 1 vhost and looks like
<VirtualHost IPNUMBER:80>
    ServerName HOSTNAME
    ServerAlias IPNUMBER
I tried several variations on this. request http://HOSTNAME works fine, request http://IPNUMBER accepts connection, but after sending request it stills. I can see TCP connection, but httpd seems to do nothing, nothing appears in logs. If you have any suggestions for obtaining more information, I can try it.
Comment 3 uhlik 2020-06-24 09:42:33 UTC
What other information should I try to provide?
Comment 4 Christophe JAILLET 2020-06-28 06:08:17 UTC
This works for me.

Could you share more of your configuration or try to have a minimal one that reproduce your issue?

Do you have anything in your logs?