Bug 35930 - Tomcat 5.5.10 not starting on Windows XP
Tomcat 5.5.10 not starting on Windows XP
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Unknown
5.5.10
Other Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
: JDK1.5
: 36087 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-07-29 16:41 UTC by Michael Mertel
Modified: 2005-08-09 12:13 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mertel 2005-07-29 16:41:44 UTC
I installed Tomcat 5.5.10 (jakarta-tomcat-5.5.10.exe) on Windows XP (SP2, 
german). Installation went through so far, but it does not start Tomcat. This 
is what the log shows (in debug mode):

[2005-07-29 16:15:29] [1253 prunsrv.c] [debug] Procrun log initialized
[2005-07-29 16:15:29] [info] Running Service...
[2005-07-29 16:15:29] [1075 prunsrv.c] [debug] Inside ServiceMain...
[2005-07-29 16:15:29] [info] Starting service...
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[0] -
Dcatalina.home=F:\Apache\Tomcat
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[1] -
Djava.endorsed.dirs=F:\Apache\Tomcat\common\endorsed
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[2] -
Djava.io.tmpdir=F:\Apache\Tomcat\temp
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[3] -
Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[4] -
Djava.util.logging.config.file=${catalina.base}\conf\logging.propertie
s
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[5] -
Djava.class.path=F:\Apache\Tomcat\bin\bootstrap.jar
[2005-07-29 16:15:29] [399  javajni.c] [debug] Jvm Option[6] vfprintf
[2005-07-29 16:15:29] [485  javajni.c] [debug] argv[0] = start

There is nothing listening on port 8080, JVM is 1.5.0_04.

If I uninstall 5.5.10 and re-install 5.5.9 with the same options selected, 
tomcat 5.5.9 starts with no probs.
Comment 1 Remy Maucherat 2005-07-29 17:37:23 UTC
The issue is that the logging configuration that is now being used in 5.5.10
uses the catalina.base env variable, which is not defined (so define it like
catalina.home).
Comment 2 Michael Mertel 2005-07-30 15:55:14 UTC
Wouldn't it be a good thing to have this defined already after installation, 
like catalina.home? 
Comment 3 Remy Maucherat 2005-08-09 10:37:09 UTC
*** Bug 36087 has been marked as a duplicate of this bug. ***
Comment 4 Ralph Casados 2005-08-09 16:45:24 UTC
(In reply to comment #2)
> Wouldn't it be a good thing to have this defined already after installation, 
> like catalina.home? Yes why isn't there any documentation on your websit to 
resolve this issue with what you mentioned.  But do you need to make this and 
environmental variable in Windows XP ? is that what you mean?
Comment 5 Michael Mertel 2005-08-09 18:43:25 UTC
Ralph, I'am not sure if your question was addressed to me, but this bug should 
definitly be fixed in the downloadable windows version, because of the missing 
environment varaible. But this can be only done by the tomcat developers. 
jakarta-tomcat-5.5.10.exe has this bug, but startup.bat in jakarta-tomcat-
5.5.10.tar.gz sets the variable, so its just an issue with the .exe
Comment 6 Remy Maucherat 2005-08-09 20:13:56 UTC
I marked the bug as fixed, which means the bug has been fixed, and I provided
you with an easy workaround, so can you please stop whining ?