Bug 56927 - Disable language change during a test
Summary: Disable language change during a test
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.11
Hardware: All All
: P3 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 58148 (view as bug list)
Depends on: 54100
Blocks:
  Show dependency tree
 
Reported: 2014-09-08 11:00 UTC by Philippe Mouawad
Modified: 2016-04-27 19:52 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2014-09-08 11:00:56 UTC
Related to bug 54100, it would be better to disable language change during a test.

There does not seem to be a valid use-case for allowing it, and disallowing the
change would solve the issue of the listeners being emptied.
Comment 1 Andreas 2014-09-08 11:48:42 UTC
I only filed 54100 because 54020 hasn't been fixed, so I was constantly running into 54100 which was very annoying and unproductive :)
Comment 2 Sebb 2014-09-08 20:23:07 UTC
(In reply to Andreas from comment #1)
> I only filed 54100 because 54020 hasn't been fixed, so I was constantly
> running into 54100 which was very annoying and unproductive :)

Bug 54020 was closed because there was insufficient information to determine whether there was a bug or not. It appeared to be a usage issue.
Comment 3 Philippe Mouawad 2014-09-08 20:33:22 UTC
@Andras,
I suppose for your issue you need to :
1/ set in jmeter.properties:
language=en
2/ Add System properties:
-Duser.language=en -Duser.country=EN

@Sebb, don't you think we should add a popup in Choose Language with those information to persist language change.
Comment 4 Sebb 2014-09-08 21:42:08 UTC
(In reply to Philippe Mouawad from comment #3)
> @Andras,
> I suppose for your issue you need to :
> 1/ set in jmeter.properties:
> language=en
> 2/ Add System properties:
> -Duser.language=en -Duser.country=EN

That info belongs in Bug 54020.

> @Sebb, don't you think we should add a popup in Choose Language with those
> information to persist language change.

Off-topic for this issue; discussions belong on mailing list
Comment 5 Philippe Mouawad 2015-08-21 12:42:02 UTC
*** Bug 58148 has been marked as a duplicate of this bug. ***
Comment 6 Philippe Mouawad 2016-04-27 19:52:50 UTC
Author: pmouawad
Date: Wed Apr 27 19:52:31 2016
New Revision: 1741323

URL: http://svn.apache.org/viewvc?rev=1741323&view=rev
Log:
Bug 56927 - Disable language change during a test
Bugzilla Id: 56927

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/gui/action/ChangeLanguage.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/xdocs/changes.xml