Bug 57972 - code fails to compile with ApacheJMeter_core and ApacheJMeter_java in pom.xml
Summary: code fails to compile with ApacheJMeter_core and ApacheJMeter_java in pom.xml
Status: RESOLVED DUPLICATE of bug 57734
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.13
Hardware: PC Mac OS X 10.4
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-29 07:42 UTC by msrikant1999
Modified: 2015-05-29 21:22 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description msrikant1999 2015-05-29 07:42:48 UTC
Here is my pom.xml


                <dependency>
                        <groupId>org.apache.jmeter</groupId>
                        <artifactId>ApacheJMeter_core</artifactId>
                        <version>2.13</version>
                        <scope>provided</scope>
                </dependency>

                <dependency>
                        <groupId>org.apache.jmeter</groupId>
                        <artifactId>ApacheJMeter_java</artifactId>
                        <version>2.13</version>
                        <scope>provided</scope>
                </dependency>


I tried to compile the code and get this error. Looks like ApacheJMeter_core depends on 'jorphan' which depends on 'commons-math3:commons-math3'. This artifactory is not available in maven repository. The repo has 'org.apache.commons:commons-math3'. Please fix the pom for 'jorphan' or remove this dependency.

[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building project1 0.0.1
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for commons-math3:commons-math3:jar:3.4.1 is missing, no dependency information available
[WARNING] The POM for commons-pool2:commons-pool2:jar:2.3 is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.097s
[INFO] Finished at: Fri May 29 07:22:44 UTC 2015
[INFO] Final Memory: 10M/106M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project project1: Could not resolve dependencies for project com.testing.loadtest:load_test_tool:jar:0.0.1: Failure to find commons-pool2:commons-pool2:jar:2.3 in http://repo1.maven.org/maven2/ was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]
[ERROR]
Comment 1 Philippe Mouawad 2015-05-29 21:22:18 UTC
Fixed in nightly build.

*** This bug has been marked as a duplicate of bug 57734 ***