Bug 59038 - Deprecate HTTPClient 3.1 related elements
Summary: Deprecate HTTPClient 3.1 related elements
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.13
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 58792 (view as bug list)
Depends on:
Blocks: 60727
  Show dependency tree
 
Reported: 2016-02-19 23:20 UTC by Philippe Mouawad
Modified: 2017-02-13 08:09 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-02-19 23:20:35 UTC
As per mailing list discussion and agreement from members:
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201512.mbox/%3CCAH9fUpZ8WMA9MBZZ8vwG%3DjCH-HhaAi8TPSMSfQ6NKcESky%2BD5Q%40mail.gmail.com%3E
Comment 1 Philippe Mouawad 2016-02-19 23:21:26 UTC
Author: pmouawad
Date: Fri Feb 19 23:21:03 2016
New Revision: 1731311

URL: http://svn.apache.org/viewvc?rev=1731311&view=rev
Log:
Bug 59038 - Deprecate HTTPClient 3.1 related elements
Bugzilla Id: 59038

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/CacheManager.java
Comment 2 Philippe Mouawad 2016-02-27 09:23:51 UTC
*** Bug 58792 has been marked as a duplicate of this bug. ***
Comment 3 Philippe Mouawad 2016-02-29 21:09:12 UTC
Author: pmouawad
Date: Mon Feb 29 21:08:39 2016
New Revision: 1732947

URL: http://svn.apache.org/viewvc?rev=1732947&view=rev
Log:
Bug 59038 - Deprecate HTTPClient 3.1 related elements
Bugzilla Id: 59038

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/control/HC3CookieHandler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC3Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPSampler2.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/SoapSampler.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/LoopbackHttpClientSocketFactory.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/SlowHttpClientSocketFactory.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml