Bug 59878 - JMeter 2.13/3.0 : Can not able to view more menu options under Sampler sub menu, by scrolling up/down.
Summary: JMeter 2.13/3.0 : Can not able to view more menu options under Sampler sub me...
Status: RESOLVED DUPLICATE of bug 56150
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: Macintosh All
: P2 critical (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-18 06:22 UTC by Srinivasa Arudra
Modified: 2016-07-31 18:53 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Srinivasa Arudra 2016-07-18 06:22:57 UTC
Hi All,

I am experiencing an issue that I can not able to view more menu options under Sampler sub menu, by scrolling up/down. Please find information regarding environment and the debug log as below. Any help on what could be the issue, could be greatly appreciated. Thanks in advance.


JMeter: 2.13/3.0
Java version: 1.8.0_91 (The issue is reproduced on 1.7.0_79 as well.)
OS: Mac OS X, EI Captain 10.11.5 (15F34)

Steps to reproduce:
1. Add a thread group.
2. Then try to add a Sampler.
3. Try to scroll up/down in Sampler sub menu, to choose newly added custom samplers.
4. Issue --> Not able to view some of the newly added samplers. And started seeing ArrayIndexOutOfBoundsException, when scrolling up/down.


Here is the debug log:

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

2016/07/18 10:25:23 DEBUG - jmeter.gui.tree.JMeterTreeListener: mouse pressed, updating currentPath

2016/07/18 10:25:23 DEBUG - jmeter.gui.tree.JMeterTreeListener: About to display pop-up

2016/07/18 10:25:23 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:23 DEBUG - jmeter.gui.GuiPackage: Updating current node Test Plan

2016/07/18 10:25:23 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:23 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:23 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:23 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:23 DEBUG - jmeter.gui.GuiPackage: Updating gui to new node

2016/07/18 10:25:23 DEBUG - jmeter.gui.GuiPackage: Showing pop up for org.apache.jmeter.gui.MainFrame$3[,0,0,182x660,alignmentX=0.0,alignmentY=0.0,border=,flags=16777576,maximumSize=,minimumSize=,preferredSize=,editable=false,invokesStopCellEditing=false,largeModel=false,rootVisible=false,rowHeight=19,scrollsOnExpand=false,showsRootHandles=true,toggleClickCount=2,visibleRowCount=20] at x,y = 76,15

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating current node Test Plan

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating current node Test Plan

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating gui to new node

2016/07/18 10:25:29 DEBUG - jmeter.gui.tree.JMeterTreeListener: value changed, updating currentPath

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating current node Test Plan

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.control.gui.TestPlanGui[Test Plan,0,0,949x660,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@3313313d,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating current node Thread Group

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating gui to new node

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating current node Thread Group

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:29 DEBUG - jmeter.gui.GuiPackage: Updating gui to new node

2016/07/18 10:25:30 DEBUG - jmeter.gui.tree.JMeterTreeListener: mouse pressed, updating currentPath

2016/07/18 10:25:30 DEBUG - jmeter.gui.tree.JMeterTreeListener: About to display pop-up

2016/07/18 10:25:30 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,949x660,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:30 DEBUG - jmeter.gui.GuiPackage: Updating current node Thread Group

2016/07/18 10:25:30 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,949x660,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:30 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:30 DEBUG - jmeter.gui.AbstractJMeterGuiComponent: setting element to enabled: true

2016/07/18 10:25:30 DEBUG - jmeter.gui.GuiPackage: Gui retrieved = org.apache.jmeter.threads.gui.ThreadGroupGui[Thread Group,0,0,949x660,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=javax.swing.border.EmptyBorder@753dea20,flags=9,maximumSize=,minimumSize=,preferredSize=]

2016/07/18 10:25:30 DEBUG - jmeter.gui.GuiPackage: Updating gui to new node

2016/07/18 10:25:30 DEBUG - jmeter.gui.GuiPackage: Showing pop up for org.apache.jmeter.gui.MainFrame$3[,0,0,182x660,alignmentX=0.0,alignmentY=0.0,border=,flags=16777576,maximumSize=,minimumSize=,preferredSize=,editable=false,invokesStopCellEditing=false,largeModel=false,rootVisible=false,rowHeight=19,scrollsOnExpand=false,showsRootHandles=true,toggleClickCount=2,visibleRowCount=20] at x,y = 131,36

2016/07/18 10:25:39 ERROR - jmeter.JMeter: Uncaught exception:  java.lang.ArrayIndexOutOfBoundsException: -4

                at org.apache.jorphan.gui.MenuScroller.refreshMenu(MenuScroller.java:552)

                at org.apache.jorphan.gui.MenuScroller.access$300(MenuScroller.java:55)

                at org.apache.jorphan.gui.MenuScroller$MouseScrollListener.mouseWheelMoved(MenuScroller.java:578)

                at java.awt.Component.processMouseWheelEvent(Component.java:6623)

                at java.awt.Component.processEvent(Component.java:6307)

                at java.awt.Container.processEvent(Container.java:2236)

                at java.awt.Component.dispatchEventImpl(Component.java:4891)

                at java.awt.Container.dispatchEventToSelf(Container.java:2318)

                at java.awt.Component.dispatchMouseWheelToAncestor(Component.java:5044)

                at java.awt.Component.dispatchEventImpl(Component.java:4778)

                at java.awt.Container.dispatchEventImpl(Container.java:2294)

                at java.awt.Component.dispatchEvent(Component.java:4713)

                at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)

                at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4554)

                at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)

                at java.awt.Container.dispatchEventImpl(Container.java:2280)

                at java.awt.Window.dispatchEventImpl(Window.java:2750)

                at java.awt.Component.dispatchEvent(Component.java:4713)

                at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)

                at java.awt.EventQueue.access$500(EventQueue.java:97)

                at java.awt.EventQueue$3.run(EventQueue.java:709)

                at java.awt.EventQueue$3.run(EventQueue.java:703)

                at java.security.AccessController.doPrivileged(Native Method)

                at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)

                at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)

                at java.awt.EventQueue$4.run(EventQueue.java:731)

                at java.awt.EventQueue$4.run(EventQueue.java:729)

                at java.security.AccessController.doPrivileged(Native Method)

                at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)

                at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)

                at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)

                at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)

                at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)

                at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)

                at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)

                at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Thanks,
Srinivasa
Comment 1 Philippe Mouawad 2016-07-31 18:53:40 UTC

*** This bug has been marked as a duplicate of bug 56150 ***