Bug 60210 - HTTP PUT & POST does NOT calculate Sent Bytes
Summary: HTTP PUT & POST does NOT calculate Sent Bytes
Status: RESOLVED DUPLICATE of bug 60229
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.13
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-06 17:13 UTC by Ahmad
Modified: 2016-10-13 18:57 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmad 2016-10-06 17:13:48 UTC
Per the discussion in 
 http://jmeter.512774.n5.nabble.com/HTTP-PUT-bytes-output-does-NOT-include-the-uploaded-file-size-td5724815.html 

Currently bytes and KB/s for PUT and POST are calculated as bytes received from server.

There needs to be a calculation for the bytes of DATA SENT (sending a File of varying sizes) and the rate KB/s which is expected for the PUT and POST operations.
Comment 1 Sebb 2016-10-07 09:17:41 UTC
If the value is calculated for HTTP requests it should be calculated for other requests too.
Comment 2 Ahmad 2016-10-07 14:36:29 UTC
Having an additional byte out field I think makes sense as well.  

Then will have to add additional field in aggregate report (and others) for Out Bytes and Out KB/s.
Comment 3 Philippe Mouawad 2016-10-12 08:39:28 UTC

*** This bug has been marked as a duplicate of bug 60229 ***
Comment 4 Ahmad 2016-10-13 18:57:48 UTC
I verified that the sentBytes is being captured in JTL file (even for over 3GB files). 
BUT the aggregate report still does NOT have Sent KB/s