Bug 60229 - Add a new metric : sent_bytes
Summary: Add a new metric : sent_bytes
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 60210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-09 14:02 UTC by Philippe Mouawad
Modified: 2016-11-07 21:56 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2016-10-09 14:02:53 UTC
As per discussion :

- http://mail-archives.apache.org/mod_mbox/jmeter-dev/201609.mbox/%3CCAH9fUpa_vesEO4C9NQNC2bpq1-FEqEKL5NTT803Rud92Q%2BawiA%40mail.gmail.com%3E

Add a new metric to have sent bytes metric in addition to received bytes.
Comment 1 Philippe Mouawad 2016-10-09 15:04:47 UTC
Author: pmouawad
Date: Sun Oct  9 15:04:10 2016
New Revision: 1763985

URL: http://svn.apache.org/viewvc?rev=1763985&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Disable sent_bytes in properties for batch
Bugzilla Id: 60229

Modified:
    jmeter/trunk/bin/testfiles/jmeter-batch.properties

Author: pmouawad
Date: Sun Oct  9 15:03:03 2016
New Revision: 1763984

URL: http://svn.apache.org/viewvc?rev=1763984&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Bugzilla Id: 60229

Modified:
    jmeter/trunk/bin/jmeter.properties
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/SamplerResultTab.java
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/TableVisualizer.java
    jmeter/trunk/src/core/org/apache/jmeter/control/TransactionController.java
    jmeter/trunk/src/core/org/apache/jmeter/report/core/Sample.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/src/core/org/apache/jmeter/samplers/SampleResult.java
    jmeter/trunk/src/core/org/apache/jmeter/samplers/SampleSaveConfiguration.java
    jmeter/trunk/src/core/org/apache/jmeter/samplers/StatisticalSampleResult.java
    jmeter/trunk/src/core/org/apache/jmeter/save/CSVSaveService.java
    jmeter/trunk/src/core/org/apache/jmeter/save/converters/SampleResultConverter.java
    jmeter/trunk/src/core/org/apache/jmeter/save/converters/SampleSaveConfigurationConverter.java
    jmeter/trunk/src/core/org/apache/jmeter/visualizers/TableSample.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/listeners.xml
Comment 2 Philippe Mouawad 2016-10-09 15:07:44 UTC
Author: pmouawad
Date: Sun Oct  9 15:07:20 2016
New Revision: 1763986

URL: http://svn.apache.org/viewvc?rev=1763986&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Update TestCSVSaveService with new field
Bugzilla Id: 60229

Modified:
    jmeter/trunk/test/src/org/apache/jmeter/save/TestCSVSaveService.java
Comment 3 Philippe Mouawad 2016-10-09 15:20:21 UTC
Author: pmouawad
Date: Sun Oct  9 15:19:50 2016
New Revision: 1763987

URL: http://svn.apache.org/viewvc?rev=1763987&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Mention metric is only available with HttpClient4
Bugzilla Id: 60229

Modified:
    jmeter/trunk/bin/jmeter.properties
Comment 4 Philippe Mouawad 2016-10-10 19:55:08 UTC
Author: pmouawad
Date: Mon Oct 10 19:30:46 2016
New Revision: 1764166

URL: http://svn.apache.org/viewvc?rev=1764166&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Add connect and sent_bytes metrics to tabbed view
Bugzilla Id: 60229

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/SamplerResultTab.java
    
    
Author: pmouawad
Date: Mon Oct 10 19:53:32 2016
New Revision: 1764171

URL: http://svn.apache.org/viewvc?rev=1764171&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Don't cumulate sent bytes to compute throughput (which is for server)
Bugzilla Id: 60229

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/report/processor/StatisticsSummaryConsumer.java
Comment 5 Philippe Mouawad 2016-10-12 08:39:28 UTC
*** Bug 60210 has been marked as a duplicate of this bug. ***
Comment 6 Ahmad 2016-10-13 18:57:33 UTC
I verified that the sentBytes is being captured in JTL file (even for over 3GB files). 
BUT the aggregate report still does NOT have Sent KB/s
Comment 7 Philippe Mouawad 2016-10-13 19:02:21 UTC
(In reply to Ahmad from comment #6)
> I verified that the sentBytes is being captured in JTL file (even for over
> 3GB files). 
Thanks
> BUT the aggregate report still does NOT have Sent KB/s

This would be another bugzilla, please open it.

For now, only HTML report has been updated, see User Manual > Generating Report Dashboard using default configuration for saveservice.


Thanks
Comment 8 Philippe Mouawad 2016-11-07 21:56:26 UTC
Author: pmouawad
Date: Mon Nov  7 21:56:03 2016
New Revision: 1768593

URL: http://svn.apache.org/viewvc?rev=1768593&view=rev
Log:
Bug 60229 - Add a new metric : sent_bytes
Add to JavaTest of Java Request
Bugzilla Id: 60229

Modified:
    jmeter/trunk/src/protocol/java/org/apache/jmeter/protocol/java/test/JavaTest.java