Bug 60239 - Report / Dashboard: add option to display error codes per request in statistic/errors sections.
Summary: Report / Dashboard: add option to display error codes per request in statisti...
Status: RESOLVED DUPLICATE of bug 60287
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-11 15:52 UTC by georgi
Modified: 2016-11-12 13:40 UTC (History)
1 user (show)



Attachments
dashboard screenshot (23.62 KB, image/png)
2016-10-11 15:52 UTC, georgi
Details
error list on hover (26.67 KB, image/png)
2016-10-12 09:05 UTC, georgi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description georgi 2016-10-11 15:52:13 UTC
Created attachment 34359 [details]
dashboard screenshot

issue: in case of multiple different failure types it is not clear what error code corresponds to specific request. Statistics table displays percentage of failed requests(without specifying error codes) and Error table displays error codes(without specifying corresponding requests).

example image attached: it is not quite clear what type of error corresponds to failed /entitlement request.
Comment 1 Philippe Mouawad 2016-10-11 15:58:20 UTC
Hello,
There has been an enhancement to the report which you can see in nightly build , see also Bug 60065.

But I am not sure this answer fully your request.
Do you have an idea of expected presentation ? As there can be a lot of different errors for a particular request.

Regards
Comment 2 georgi 2016-10-12 09:05:14 UTC
Created attachment 34364 [details]
error list on hover
Comment 3 georgi 2016-10-12 09:10:40 UTC
Not sure what is the best way to handle variety of different errors.
One possible option is to display error list when hovering over KO cell in statistic table (image attached).
Comment 4 Philippe Mouawad 2016-11-12 13:40:34 UTC
Hello,
The Top5 errors per sampler seems a way to do what was suggested here.

So I am closing this one as duplicate.
@reporter, if you disagree feel free to reopen with additional ideas.
Thanks

*** This bug has been marked as a duplicate of bug 60287 ***