Bug 61058 - HTTP Request : Add option "httpclient4.deflate_relax_mode" to avoid "Unexpected end of ZLIB input stream" when deflating what seems to be invalid streams
Summary: HTTP Request : Add option "httpclient4.deflate_relax_mode" to avoid "Unexpect...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 3.2
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 62225 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-01 14:00 UTC by Philippe Mouawad
Modified: 2018-04-08 08:35 UTC (History)
4 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2017-05-01 14:00:03 UTC
Reported on JMETER-FR google group:

- https://groups.google.com/d/msg/jmeter-fr/SWLhaYP7qvM/O8HDThI4DgAJ

User getting:

java.io.EOFException: Unexpected end of ZLIB input stream
	at java.util.zip.InflaterInputStream.fill(Unknown Source)
	at java.util.zip.InflaterInputStream.read(Unknown Source)
	at org.apache.http.client.entity.DeflateInputStream.read(DeflateInputStream.java:88)
	at org.apache.http.client.entity.LazyDecompressingInputStream.read(LazyDecompressingInputStream.java:70)
	at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:135)
	at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:148)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.readResponse(HTTPSamplerBase.java:1814)
	at org.apache.jmeter.protocol.http.sampler.HTTPAbstractImpl.readResponse(HTTPAbstractImpl.java:440)
	at org.apache.jmeter.protocol.http.sampler.HTTPHC4Impl.sample(HTTPHC4Impl.java:433)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerProxy.sample(HTTPSamplerProxy.java:74)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1189)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:1178)
	at org.apache.jmeter.threads.JMeterThread.executeSamplePackage(JMeterThread.java:491)
	at org.apache.jmeter.threads.JMeterThread.processSampler(JMeterThread.java:425)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:254)
	at java.lang.Thread.run(Unknown Source)
Comment 1 Philippe Mouawad 2017-05-01 14:05:49 UTC
The target application is SIEBEL CRM.
Comment 2 Philippe Mouawad 2017-09-19 19:20:37 UTC
See:

https://issues.apache.org/jira/browse/HTTPCLIENT-1869
Comment 3 Philippe Mouawad 2017-10-24 08:58:44 UTC
See :

- https://issues.apache.org/jira/browse/HTTPCLIENT-1877
Comment 5 Philippe Mouawad 2018-03-06 16:21:21 UTC
Author: pmouawad
Date: Tue Mar  6 16:20:04 2018
New Revision: 1825998

URL: http://svn.apache.org/viewvc?rev=1825998&view=rev
Log:
Bug 61058 - HTTP Request : Deflate triggers "Unexpected end of ZLIB input stream"
Contributed by UbikLoadPack
Bugzilla Id: 61058

Added:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/hc/LaxDeflateInputStream.java   (with props)
Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/xdocs/changes.xml
Comment 6 Philippe Mouawad 2018-03-06 16:28:21 UTC
Lax mode can be enabled by setting in user.properties:

- httpclient4.deflate_relax_mode=true
Comment 7 Philippe Mouawad 2018-03-09 11:23:21 UTC
Fix confirmed.
Comment 8 Philippe Mouawad 2018-03-28 05:52:23 UTC
*** Bug 62225 has been marked as a duplicate of this bug. ***