Bug 62234 - Search/Replace Feature : Enhance UX and add Replace/Next/Previous/Replace & Find features
Summary: Search/Replace Feature : Enhance UX and add Replace/Next/Previous/Replace & F...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 4.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 61812 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-29 18:35 UTC by UbikLoadPack support
Modified: 2018-06-03 19:40 UTC (History)
1 user (show)



Attachments
Screenshot showing dialog (80.12 KB, image/png)
2018-03-29 18:35 UTC, UbikLoadPack support
Details
Patch implementing feature (22.99 KB, patch)
2018-03-29 18:39 UTC, UbikLoadPack support
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description UbikLoadPack support 2018-03-29 18:35:37 UTC
Created attachment 35825 [details]
Screenshot showing dialog

Currently Search / Replace dialog offers:
- Search All
- Replace All

This is not complete so we propose to add:

- Next: Search for text and go to next node
- Previous: Search for text and go to previous node
- Rename Search to "Search All" as this is what it does
- Rename "Search & Expand" to "Search All & Expand" as this is what it does
- Replace : Replace only in current node
- Replace & Find : Replace in current node and go to next node
Comment 1 UbikLoadPack support 2018-03-29 18:39:04 UTC
Created attachment 35826 [details]
Patch implementing feature
Comment 2 Philippe Mouawad 2018-03-29 18:47:14 UTC
Author: pmouawad
Date: Thu Mar 29 18:44:27 2018
New Revision: 1828013

URL: http://svn.apache.org/viewvc?rev=1828013&view=rev
Log:
Bug 62234 - Search/Replace Feature : Enhance UX and add Replace/Next/Previous/Replace & Find features
Contributed by Ubik Load Pack (support at ubikloadpack.com)
Bugzilla Id: 62234

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/gui/action/RawTextSearcher.java
    jmeter/trunk/src/core/org/apache/jmeter/gui/action/SearchTreeDialog.java
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/xdocs/changes.xml
Comment 3 Philippe Mouawad 2018-06-03 19:40:10 UTC
*** Bug 61812 has been marked as a duplicate of this bug. ***