Bug 64821 - Transaction controller renames child samplers in VRT and VRT Http2 listeners
Summary: Transaction controller renames child samplers in VRT and VRT Http2 listeners
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.3
Hardware: PC All
: P2 major (vote)
Target Milestone: JMETER 5.4.1
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-17 19:40 UTC by eR@SeR
Modified: 2020-12-19 12:06 UTC (History)
1 user (show)



Attachments
jmx file (19.52 KB, application/xml)
2020-10-17 19:40 UTC, eR@SeR
Details
XML formatted JTL file with sub results to show the problem (5.00 KB, application/xml)
2020-11-30 16:30 UTC, Felix Schumacher
Details
Fix for renaming of sub results on loading in VRT (1.94 KB, patch)
2020-11-30 17:00 UTC, Felix Schumacher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description eR@SeR 2020-10-17 19:40:48 UTC
Created attachment 37506 [details]
jmx file

Hello,

Transaction controller renames child samplers in VRT and VRT Http2 listeners. Here are the steps:

1. Run provided jmx file (all child samplers names are fine)
2. Click on Browse button in VRT or VRT Http2 listener and load "someJTLFile.jtl" file
3. Observe

Precondition:

All checkboxes are ticked in Configuration setting in VRT or any other listener.

Actual:

All child samplers are renamed to "Transaction controller-0" etc. (suffix is incremented by 1). It happens only if generate parent sample is checked in Transaction controller. "lb" parameter in jtl file is not renamed though.

Jmeter 5.3
Microsoft Windows 10 Enterprise 64-bit
java version "14.0.1" 2020-04-14

Note: Issue might be present in some other listeners, so if you have time please investigate. Thank you.
Comment 1 Felix Schumacher 2020-11-29 12:15:15 UTC
This seems to be a report about third party components. Feel free to re-open this issue, if you can reproduce the problems without any third party components.
Comment 2 eR@SeR 2020-11-29 23:35:19 UTC
Hello,

Yes, it can be reproduced without any 3rd party components. Just remove all of them. IDK why didn't you try it using without 3rd party components before marking this thread as invalid? :/
Comment 3 Felix Schumacher 2020-11-30 16:27:40 UTC
Thanks for your insistence. I can reproduce this. The minimal test plan would have been a single element: View Results Tree and a xml formatted JTL file with a subresult inside a transaction controller. Expectation is, that loading such a JTL would keep the names of the samples. Observation is, that the names of the sub results will get renamed to "transaction controller-X".

I am looking into this, and believe, that this is a "feature" of the XStreams library that is being used to de-serialize the XML. I am not sure, how far I get there, so if anyone more familiar with the library wants to have a look at it, feel free to do so :)
Comment 4 Felix Schumacher 2020-11-30 16:30:11 UTC
Created attachment 37580 [details]
XML formatted JTL file with sub results to show the problem
Comment 5 Felix Schumacher 2020-11-30 17:00:05 UTC
Created attachment 37581 [details]
Fix for renaming of sub results on loading in VRT

This seems to be a collateral damage from fixing Bug 62648. The default for SampleResult#storeSubResult was changed from not renaming to renaming sub results. This is good, if we want to create new sub samplers, it is not that good, if we want to restore sub samplers.
Comment 6 Felix Schumacher 2020-12-06 10:38:50 UTC
@OP, can you try the next nightly build and report back, whether it fixes your problem?

commit a568c86405b3473e428ddd192c19a3495858b7bc
Author: Felix Schumacher <felix.schumacher@internetallee.de>
AuthorDate: Sun Dec 6 11:35:09 2020 +0100

    When importing XML formatted jtl files, sub samplers will get renamed
    
    Bugzilla Id: 64821
---
 src/core/src/main/java/org/apache/jmeter/samplers/SampleResult.java   | 4 ++--
 .../java/org/apache/jmeter/save/converters/SampleResultConverter.java | 2 +-
 xdocs/changes.xml                                                     | 1 +
 3 files changed, 4 insertions(+), 3 deletions(-)
Comment 7 eR@SeR 2020-12-06 23:30:05 UTC
Hi Felix,

I checked commit: c7f309f and it seems that the issue has been fixed for the provided jmx file. In up to few days, I will check the real test plan and let you know the results.

P.S. It will be highly appreciated if you add the fix as a hotfix to the released 5.4 version, to avoid waiting for several months for the next one. Thank you very much in advance.
Comment 8 eR@SeR 2020-12-07 22:02:04 UTC
Hi Felix,

I checked the real test plan. The issue has been fixed when jtl file is loaded. Thank you.