This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 255821 - Proxy and browser settings not imported from ZIP exported from 8.0.2 to 8.1RC
Summary: Proxy and browser settings not imported from ZIP exported from 8.0.2 to 8.1RC
Status: NEW
Alias: None
Product: ide
Classification: Unclassified
Component: Import Settings (show other bugs)
Version: 8.2
Hardware: PC Linux
: P4 normal (vote)
Assignee: Theofanis Oikonomou
Depends on:
Reported: 2015-10-09 07:48 UTC by Vladimir Riha
Modified: 2015-10-09 13:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:

exported settings from 8.0.2 (105.91 KB, application/zip)
2015-10-09 07:48 UTC, Vladimir Riha

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2015-10-09 07:48:26 UTC
Created attachment 156641 [details]
exported settings from 8.0.2

Please try to:
 - run full 8.0.2 distribution, activate all modules except of CND and Groovy
 - go to Tools -> Options and set proxy to "No proxy" and Web Browser to "Embedded Webkit browser"
 - press Apply
 - export settings
 - start full 8.1 RC distro, do not import settings upon IDE start
 - go to Tools -> Options
 - import the exported settings
 => Browser and Proxy settings are not imported to the 8.1RC

Thank you

Product Version: NetBeans IDE 8.1 RC (Build 201510012201)
Java: 1.8.0_60; Java HotSpot(TM) Client VM 25.60-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_60-b27
System: Linux version 3.13.0-35-generic running on i386; UTF-8; en_US (nb)
Comment 1 Jiri Kovalsky 2015-10-09 08:53:31 UTC
Strange. This worked fine for me when I was importing from 8.0 via its userdir. Can you Lado try to reproduce it this way i.e. not via ZIP file?
Comment 2 Vladimir Riha 2015-10-09 09:15:31 UTC
Will do. I tried to find this setting in the exported zip but wasn't successful. Maybe this settings is not being exported?
Comment 3 Vladimir Riha 2015-10-09 09:31:05 UTC
Yes, it seems to be only ZIP issue. Importing 802 userdir to 81RC during startup worked for me as well.
Comment 4 Theofanis Oikonomou 2015-10-09 11:03:48 UTC
hmmm this is strange. I cannot reproduce when I export the settings zip from my own installation of 8.0.2, but can reproduce when I try to import the attached zip file. The required settings are in config/Preferences/org/netbeans/ file and are exported as they should. At least so I think.
Comment 5 Vladimir Riha 2015-10-09 13:33:20 UTC
One thing I forgot to mention that I exported only General and Editor categories (and excluded Macro from Editor category)