This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 268016 - IllegalArgumentException: The file /Users/asand/NetBeansProjects/fim/node_modules/react-ui-library/src/css/qualys.css is not owned by QuerySupport roots: /Users/asand/NetBeansProjects/fim/src/test/jav
Summary: IllegalArgumentException: The file /Users/asand/NetBeansProjects/fim/node_mod...
Alias: None
Product: web
Classification: Unclassified
Component: CSS Editor (show other bugs)
Version: Dev
Hardware: All All
: P3 normal (vote)
Assignee: Milutin Kristofic
Depends on:
Reported: 2016-09-14 10:37 UTC by Exceptions Reporter
Modified: 2017-05-30 12:52 UTC (History)
14 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 226224

stacktrace (3.13 KB, text/plain)
2016-09-14 10:37 UTC, Exceptions Reporter
IDE log (648.84 KB, text/plain)
2016-10-05 18:20 UTC, zmirc

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-09-14 10:37:07 UTC
This bug was originally marked as duplicate of bug 251715, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201609070002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.101-b13, Java(TM) SE Runtime Environment, 1.8.0_101-b13
OS: Mac OS X

User Comments:
GUEST: Very annoying popup coming always up. Please solve asap.

I was just adding some css classes to an HTML element in HTML editor. The project is HTML5 + sass. Yesterday I had the same problem editing .sass.

The worst part about this isn't the error itself, but that popup that is raised on each exception. To my advice, it should be raised only when the exception will crash the IDE, otherwise a non-modal balloon in the bottom right corner is far enough, because I have to continue working even if a parser fails.

GUEST: I was writing header's id name

GUEST: autocomplete in LESS files


GUEST: Just noticed this issue in my notifications while working on a project.

GUEST: Editing a css file

jmorenov: java.lang.IllegalArgumentException: The file /opt/lampp/htdocs/cdn/DataTables/media/css/jquery.dataTables.css is not owned by QuerySupport roots: /opt/lampp/htdocs/ambiensQ
	at org.netbeans.modules.css.indexing.api.CssIndex.getIndexModel(
	at org.netbeans.modules.css.prep.editor.CPUtils.getIndexModels(
	at org.netbeans.modules.css.prep.editor.CPCssEditorModule.getVariableCompletionProposals(
	at org.netbeans.modules.css.prep.editor.CPCssEditorModule.getCompletionProposals(
	at org.netbeans.modules.css.editor.module.CssModuleSupport.getCompletionProposals(
	at org.netbeans.modules.css.editor.csl.CssCompletion.complete(
	at org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.addCodeCompletionItems(GsfCompletionPr

jordao: compile less file i think

zmirc: Same

GUEST: i get many times

GUEST: <Please provide a description of the problem or the steps to reproduce>aaa

GUEST: <Please provide a description of the problem or the steps to reproduce>
no show secgesstion

GUEST: None special

zmirc: I triggered autocomplete in a LESS file.

GUEST: No data

GUEST: a.bx_catalog_list_home .bx_bt_button_type_2 {
    border: 1px solid #e9e9e9;
    background-image: -webkit-gradient(linear, 0 0, 0 100%, from(#fcfcfc), to(#f1f1f1));
    background-image: -webkit-linear-gradient(#fcfcfc 0%, #f1f1f1 100%);
    background-image: -moz-linear-gradient(#fcfcfc 0%, #f1f1f1 100%);
    background-image: -o-linear-gradient(#fcfcfc 0%, #f1f1f1 100%);
    background-image: linear-gradient(#fcfcfc 0%, #f1f1f1 100%);
    color: #656565;
    text-shadow: 0 1px 0 #fff;

jordao: saving a less file

zmirc: This time I was simply typing some code in a .less file, same file as in the previous error report.


GUEST: Adding an attribute to an SCSS class

JanGen: Problem editing less file that import other less files through symlinks on Ubunu 14.04

qingyue: while write css or php file

GUEST: write @import "compass","setting"; to scss file.
and type 'm'.
and save the file.

zmirc: Same story

GUEST: just typing

GUEST: I don't know... suddenly this happens

Murlika: on typing all css rules

GUEST: no plan

bhansma: Editing CSS. Autocompletion not working in CSS.

GUEST: Just coding and I got the error

GUEST: CTRL+BARRA DE ESPACO em arquivo css. Nao ativa autocompletion

GUEST: it looks like it's related to CSS autocompletion that doesn't work anymore

GUEST: the file is a php file, I was changing inline sytle in an HTML <a>  tag

GUEST: Developing Firefox Addon using Mozilla Addons SDK.
Project configured in Netbeans 8.1 as a nodejs project.

GUEST: CTRL+SPACEBAR into css file

Murlika: then I edit css file with links to the outer of project file

GUEST: <Please provide a description of the problem or the steps to reproduce>d

giraam: I was just editing a css file

GUEST: Editing a SCSS source file, Exception thrown on every line change.

zmirc: Same error with .less referenced from outside Project's App folder

zmirc: I simply can't use NetBeans with this error.
It appears after EACH key pressed on the keyboard inside a .less file. X_X :(((((
Please fix it.

zmirc: I can't use CTRL+SPACE (autocompletion suggestions) neither because of this error.

zmirc: Same error even with NB 8.1 201510020002

GUEST: !!!!!!!

GUEST: I don't touch anything while the error appears. I only change the focus of the window to the projects panel.

GUEST: No data No step

GUEST: i don't know

Comment 1 Exceptions Reporter 2016-09-14 10:37:13 UTC
Created attachment 162044 [details]
Comment 2 Milutin Kristofic 2016-10-05 13:35:42 UTC
The only report after fix in Bug #251715 is report .

If the user with file system like this  /Users/asand/NetBeansProjects/fim/node_modules/react-ui-library/src/css/qualys.css is not owned by QuerySupport roots: /Users/asand/NetBeansProjects/fim/src/test/java, /Users/asand/NetBeansProjects/fim/src/main/webapp, /Users/asand/NetBeansProjects/fim/src/main/java 

has time, please reopen this issue and can explain me how this css file is in directory. Otherwise I close this as incomplete.
Comment 3 zmirc 2016-10-05 18:20:12 UTC
Here it is again. CTRL + Space fails inside css/less file when dependencies (bower_components folder) is outside the app folder of the NetBeans HTML 5 project.
This error has never stopped happening, just that I got bored of reporting it.
NetBeans 201610010002
Comment 4 zmirc 2016-10-05 18:20:20 UTC
Created attachment 162355 [details]
IDE log