This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 270829 - NullPointerException at java.util.Hashtable.put
Summary: NullPointerException at java.util.Hashtable.put
Status: NEW
Alias: None
Product: web
Classification: Unclassified
Component: Cordova (show other bugs)
Version: 8.2
Hardware: All All
: P3 normal (vote)
Assignee: Tomas Stupka
Depends on:
Reported: 2017-06-08 00:49 UTC by alexsmarquez
Modified: 2018-05-04 21:05 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 229397

stacktrace (760 bytes, text/plain)
2017-06-08 00:49 UTC, alexsmarquez

Note You need to log in before you can comment on or make changes to this bug.
Description alexsmarquez 2017-06-08 00:49:24 UTC
This bug was originally marked as duplicate of bug 244651, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 8.2 (Build 201705191307)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.131-b11, Java(TM) SE Runtime Environment, 1.8.0_131-b11
OS: Windows 10

User Comments:
GUEST: Create a new Crodova Hellow World project, attempt to run project while Android Emulator is running.

GUEST: Tried running cordova application

GUEST: Run freshly made Cordova project

GUEST: Tried to run a cordova project

GUEST: Impossible to debug in emulator or device(android)

GUEST: set android_home variable environment

alexsmarquez: Hello, whats up!
 I was running an application demo when the problem happening, occur before appear the content in android emulator, and don't initiates emulation.


GUEST: Create a new Oracle JET sample application
Run project to android device

GUEST: trying to run a cordova android application.

SDK is installed and using commandline to build and deploy to android works.
Just does not work with netbeans.

GUEST: Attempting to deploy a cordova app on the (running) Android Emulator

GUEST: Tried to build cordova application for android

GUEST: it does not run the Cordova application

GUEST: Building a Cordova app to device

GUEST: I was trying to run the Cordova (Android Emulator). My Android Emulator was running before I ran my project.

   at java.util.Hashtable.put(
   at org.netbeans.modules.cordova.CordovaPerformer.access$200(
   at org.netbeans.modules.cordova.CordovaPerformer$
   at org.openide.util.RequestProcessor$
Comment 1 alexsmarquez 2017-06-08 00:49:27 UTC
Created attachment 164485 [details]
Comment 2 Exceptions Reporter 2018-04-08 05:35:48 UTC
This bug already has 50 duplicates 
Comment 3 Exceptions Reporter 2018-04-08 05:44:48 UTC
This bug already has 50 duplicates 
Comment 4 Exceptions Reporter 2018-04-08 05:53:48 UTC
This bug already has 50 duplicates 
Comment 5 Exceptions Reporter 2018-04-08 06:02:48 UTC
This bug already has 50 duplicates