This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 43644 - Poor naming scheme: addPathRegistryListener(GlobalPathRegistryListener)
Summary: Poor naming scheme: addPathRegistryListener(GlobalPathRegistryListener)
Alias: None
Product: java
Classification: Unclassified
Component: Unsupported (show other bugs)
Version: 4.x
Hardware: All All
: P3 blocker (vote)
Assignee: Jesse Glick
Keywords: API
Depends on:
Blocks: 41535
  Show dependency tree
Reported: 2004-05-20 18:47 UTC by Jesse Glick
Modified: 2007-09-26 09:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-05-20 18:47:16 UTC
I will change the methods
add/removePathRegistryListener in
GlobalPathRegistry to be
add/removeGlobalPathRegistryListener. Not just
cosmetic: if you don't use the special 4-arg form
of WeakListeners.create, you get a memory leak. I
wouldn't expect most users of the API to notice
this, and in fact it seems that the refactoring
build contained this error; WeakListeners prints a
warning to that effect on console. So will just
change the name to a safer form that should work
correctly with the 3-arg variant of WL.c.
Comment 1 Jesse Glick 2004-05-20 18:48:43 UTC
committed   * Up-To-Date  1.4        
committed   * Up-To-Date  1.4        
committed   * Up-To-Date  1.4