Issue 101657 - Draw object not selectable in 3.x. Was in 2.x
Summary: Draw object not selectable in 3.x. Was in 2.x
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: All All
: P3 Trivial with 16 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2009-05-07 20:08 UTC by snoiraud
Modified: 2017-05-20 11:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

This document is not editable in 3.0, 3.0.1 (4.60 KB, application/vnd.oasis.opendocument.text)
2009-05-07 20:09 UTC, snoiraud
no flags Details
Same as the first document. The validator is OK (4.72 KB, text/plain)
2010-03-21 22:03 UTC, snoiraud
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description snoiraud 2009-05-07 20:08:35 UTC
We used to create documents in gramps project for genealogy
If we open them in OOo 2.4.1, we can edit them.
If we open them in OOo 3.0 or 3.0.1, we cannot edit them.
The problem occurs only when we have draw box in them.

I looked at the internal structure, but for me, I don't see errors.
gramps generate document normaly conform to odf 1.0

I would like to know if it is an OOo regression or a programming problem ?

I have a small example.
Comment 1 snoiraud 2009-05-07 20:09:41 UTC
Created attachment 62081 [details]
This document is not editable in 3.0, 3.0.1
Comment 2 eric.savary 2009-05-08 09:59:53 UTC
@MBA: I don't know what happens there. The Draw object is not read-only but just
cannot be selected using the mouse.
It works using Shift+F4 (select first object) then traveling with Tab.

No idea if it is a Writer or Draw problem.
Please dispatch.
Comment 3 Mathias_Bauer 2009-05-08 15:42:25 UTC
Oliver, one for you, I assume
Comment 4 snoiraud 2009-09-05 20:10:06 UTC
The problem always occurs with 3.1.1.
Comment 5 Oliver-Rainer Wittmann 2009-09-10 14:37:49 UTC
Unfortunately, I have to re-target this issue to the next release due to limited
Comment 6 Oliver-Rainer Wittmann 2009-12-03 15:16:42 UTC
It is not clear due to limited resources, if this issue can be solved for OOo
3.3. to be honest I am adjusting the target.
Comment 7 snoiraud 2010-03-21 22:03:55 UTC
Created attachment 68462 [details]
Same as the first document. The validator is OK
Comment 8 snoiraud 2010-03-21 22:08:36 UTC
I added the same document which now pass the validator.
On the first document, we had the error : 
upload:///Example.odt/content.xml[22,23]:Error:unexpected attribute "office:class"
This was not the reason as the problem is always here.
Comment 9 Regina Henschel 2010-03-22 00:16:50 UTC
I cannot confirm it. Remember, that you need to use Ctrl+click to access an
object which is background.
Comment 10 snoiraud 2010-03-23 07:46:49 UTC
Perhaps it's an object in the background.
I never say this object must be in the background.
We have two solves this :
 1 - How can I say this object must be in foreground ?
 2 - This is a regression as it worked in the 2.x versions, so it is a bug.
Comment 11 snoiraud 2010-03-25 21:32:05 UTC
OK. You pointed me to the solution with run-through=background.
I have no more this problem now and I think you can close this issue.

If it worked before, perhaps this means it was a bug in 2.x version of OOo
and not in 3.x
Comment 12 Marcus 2017-05-20 11:15:57 UTC
Reset assigne to the default "".