Issue 111685 - OOo version 3.2.0 crashes when loading spreadsheets prepared on earlier versions
Summary: OOo version 3.2.0 crashes when loading spreadsheets prepared on earlier versions
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO320m12
Hardware: PC Unix, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2010-05-18 17:36 UTC by maxcel
Modified: 2013-07-29 17:55 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

This file, with four sheets, loads and runs (21.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-05-18 17:38 UTC, maxcel
no flags Details
This file with five sheets crashes Calc before loading, consistently on both computers. (22.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-05-18 17:40 UTC, maxcel
no flags Details
Log of attempt to convert OpenOffice_org-calc-debuginfo- to deb (3.39 KB, text/plain)
2010-05-21 14:47 UTC, maxcel
no flags Details
Strace of failed load of the original copy of Test-OOo3.2-5sheet.ods (1.39 MB, text/plain)
2010-05-21 20:18 UTC, maxcel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description maxcel 2010-05-18 17:36:30 UTC
I have spreadsheets which were generated and edited in both OOo 3.0 and 3.1
which I am now trying to open in 3.2. all are saved in .ods format. Most crash
OOo without even loading, but leaving them locked. 

I have been conducting test using OOo 3.1 Calc to generate workbooks of varying
size and have discovered that any file over about 21KB will cause them to crash.
I have two computers with Ubuntu 10.04 and OOo 3.2.0 and the behavior is
identical on both. 

The problem does not exist with OOo 3.2.0 on WindowsXP. The only common factor
between the two Ubuntu computers is that they have both been updated from
earlier releases of Ubuntu.

I have sample files, but cannot see where to attach them.
Comment 1 maxcel 2010-05-18 17:38:21 UTC
Created attachment 69519 [details]
This file, with four sheets, loads and runs
Comment 2 maxcel 2010-05-18 17:40:10 UTC
Created attachment 69520 [details]
This file with five sheets crashes Calc before loading, consistently on both computers.
Comment 3 Joost Andrae 2010-05-19 10:14:33 UTC
the file doesn't crash my OOo 3.2.1rc1 (tested on Solaris x86)
Comment 4 maxcel 2010-05-19 11:28:19 UTC
I am not surprised that it worked on Solaris. You will observe that I said that
it worked on Windows. The issue is that it does not work on two very different
computers, both with Ubuntu 10.04.
Comment 5 Mechtilde 2010-05-19 12:03:09 UTC
this worksforme with the Debian version of 3.2.1 RC1.

You use the Ubuntu version of

@ ccheney please have a look

Comment 6 maxcel 2010-05-19 16:07:52 UTC
Yes, as bundled with Ubuntu 10.04 discs.
Comment 7 ccheney 2010-05-19 19:26:46 UTC
Works for me on Ubuntu 10.04 with 1:3.2.0-7ubuntu4 on amd64 (64bit).
Comment 8 Mechtilde 2010-05-19 19:32:40 UTC
so set to worksforme
Comment 9 Mechtilde 2010-05-19 19:33:05 UTC
-> closed
Comment 10 maxcel 2010-05-19 20:15:37 UTC
Sorry, still does not work for me on freshly installed, not upgraded, Ubuntu
10.04LTS -i386, updated.
Comment 11 Mechtilde 2010-05-20 08:19:53 UTC
Nobody can reproduce thei probllem here so nobody can get an idea what is wrong an can be fixed

I reassign 

Maybe more people can have a look to reproduce it. But I doubt someone can reproduce it
Comment 12 2010-05-20 09:05:27 UTC
I cannot reproduce it with go-oo 3.2.0 or 3.2.1 too.
Closing it as invalid once again.
Comment 13 kendy 2010-05-20 13:25:51 UTC
As nobody here is able to reproduce, can you please try to create a backtrace 
of the crash for us?  Please see these instructions:

They are for openSUSE, but should work very similarly for Ubuntu too.
Comment 14 maxcel 2010-05-20 23:54:35 UTC
I have copied the uploaded files to the same location on my server as the
original and I agree that the files attached to this Issue do run correctly,
however, the original file still crashes. Can anyone explain why the same file,
uploaded, runs o.k. whilst the original does not? Is it possible that something
in the file has been modified by the process of uploading, so that it is now
recognised by OOo?
Comment 15 kendy 2010-05-21 00:36:24 UTC
You can use md5sum to check that the files are identical.  Either way, without 
the failing document & the backtrace, we cannot help much :-(
Comment 16 maxcel 2010-05-21 14:19:55 UTC
Thank you Kendy for your suggestions. md5sum is identical for both files, so
that seems to rule out file changes.

I have also installed OOo 3.2.1.rc1 and get the same result of failure to load
the original file, but the uploaded/downloaded file is o.k.

I have downloaded the rpm file from opensuse, but
cannot convert it to deb. The log of alien is attached.

Does anyone know of a debug that would work with Ubuntu (deb)?
Comment 17 maxcel 2010-05-21 14:47:03 UTC
Created attachment 69556 [details]
Log of attempt to convert OpenOffice_org-calc-debuginfo- to deb
Comment 18 kendy 2010-05-21 16:11:31 UTC
maxcel: That won't work; you'd have to install the appropriate debuginfo from
your distro.  Please try to do the backtrace without the debuginfo packges.

One thing totally confuses me - you say that the files are identical.  What do
you mean then that 'the downloaded does not work, and the orignal does'?  What
are the exact locations of those files?  Also strace might be useful here, see (and actually easier than
getting the backtrace).
Comment 19 maxcel 2010-05-21 20:18:25 UTC
Created attachment 69560 [details]
Strace of failed load of the original copy of Test-OOo3.2-5sheet.ods
Comment 20 ccheney 2010-05-21 20:29:20 UTC

Unfortunately the Ubuntu 10.04 debug debs for 3.2.0 got lost somehow, but once I
do an upload of 3.2.1 for 10.04.1 in a few weeks those should be available.
Comment 21 maxcel 2010-05-22 08:47:45 UTC
After a lot more testing, it looks as if this is a network related problem,
possibly timing.

All my files are stored on a NAS file server.

Working exclusively with OOo3.2.0 and OOo3.2.1.rc1. When .ods spreadsheets are
called up directly from the server, they invariably crash. If the same files are
copied to the local drive, or a USB stick, they run properly. If they are
modified and saved back to the local drive they will load again properly, but if
they are saved back to the NAS, they will again crash on loading. This behavior
is consistent and repeatable over many different files.

A clue here is that the crash happens very soon after the splash screen and
before OOo displays the normal working screen.

I have used the built-in bug reporting feature on OOo3.2.1.rc1 to log the
crashes which are occurring on that version.

Just a reminder that this behavior only started with OOo3.2.0. I still have some
computers with OOo3.1 and earlier and can confirm that the crashes do not happen
with them.
Comment 22 maxcel 2010-05-22 15:00:04 UTC
The same problem is occurring with OOo-3.2.1.rc1-Writer when trying to open
files stored on the NAS, so this problem isn't confined to Calc.
Comment 23 ccheney 2010-05-22 19:16:48 UTC
The crash on NAS is a known issue, which is apparently related to locking. If
you use nobrl for the cifs mount it should work. I have updated ooo-build to not
use locking for cifs mounts and will be adding the patch to Ubuntu 10.04.1 build.

There are 11 other cifs bugs in the issue tracker at the moment, and I wouldn't
be surprised if they are all related to the locking issue.
Comment 24 maxcel 2010-05-22 20:07:07 UTC
Adding nobrl to the cifs mount has solved the problem. Many thanks to all who
have helped, especially ccheney. I am happy to close this issue now.
Comment 25 Mechtilde 2010-05-23 08:38:12 UTC
-> closed
Comment 26 ccheney 2010-05-30 05:25:07 UTC
Am I wrong here or isn't the fact that you have to turn on 'nobrl' to make OOo
work with cifs still a bug in OOo.

What 'nobrl' does is the following:

    Do not send byte range lock requests to the server. This is
    necessary for certain applications that break with cifs style
    mandatory byte range locks (and most cifs servers do not yet
    support requesting advisory byte range locks).

This is now worked around by ooo-build but as far as I know this wouldn't this
still affect the official version?
Comment 27 kendy 2010-06-03 15:47:20 UTC
ccheney: Can you please attach here the patch?
Comment 28 ccheney 2010-06-03 16:30:09 UTC

My patch would not apply cleanly to official OOo 3.2 as it simply extends the
check to see if it is on smb or nfs and to disable locking entirely. I'm not
sure who originally wrote the patch but perhaps they can contribute it back to
upstream? I hereby authorize my simple addition of 'cifs' to the patch to be
contributed upstream. :-)

Its in ooo-build's version of:


And that really that is more of a workaround for OOo's broken locking handling
at least from what I understand of 'nobrl' being able to fix the situation.
Comment 29 thb 2010-06-19 16:18:03 UTC
@kendy, I think Chris' question was for us. :)
Comment 30 thb 2010-06-19 16:18:38 UTC
Comment 31 Mechtilde 2011-03-06 12:12:27 UTC
worksforme in OOO330 go-oo bug only

don't know how to change the status