Issue 114080 - Erorr in desktop::copy_recursive() (userinstall.cxx) when a directory should be copied which only contains a symlink
Summary: Erorr in desktop::copy_recursive() (userinstall.cxx) when a directory should ...
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.2.1
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needhelp, needmoreinfo
Depends on:
Reported: 2010-08-24 09:49 UTC by chehrlic
Modified: 2014-03-01 19:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description chehrlic 2010-08-24 09:49:37 UTC
While digging down a startup error on one of our machines (terminate called
after throwing an instance of 'com::sun::star::uno::RuntimeException')
I came across the copy_recursive() function which returned E_NAMETOOLONG. The
problem seems to be that my /usr/lib64/ooo3/basis3.2/presets/config contained a
symlink to a non-existant file.
I tried to reproduce it on another system and found out that it only occours
when the *first* file in the directory is an invalid symlink. So it's easy to

1. save your content of /usr/lib64/ooo3/basis3.2/presets/config
2. remove all files in /usr/lib64/ooo3/basis3.2/presets/config
3. create an invalid symlink inside /usr/lib64/ooo3/basis3.2/presets/config
(e.g. "ln -s /i/do/not/exist .")
4. save your ~/.ooo and remove this directory so soffice needs to recreate it
5. start soffice and wait for a crash.
6. remove /usr/lib64/ooo3/basis3.2/presets/config/exist and start soffice again
- all works fine

When debugging you'll see that copy_recursive tries to create
... until the filename gets too long.

System: OpenSUSE 11.x 64Bit, OpenOffce 3.2.1, filesystem reiserfs or xfs
Comment 1 Olaf Felka 2010-08-24 10:32:41 UTC
Is this reproducible in a native OOo (
Comment 2 chehrlic 2010-08-24 11:35:46 UTC
I guess it took you more time to write this than actually trying it by yourself...

And yes, I downloaded 200MB and tried it with OOO320_m18_native_packed-1_de.9502
and the same problem occurred.
Comment 3 Rob Weir 2013-02-02 03:00:34 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
Comment 4 Edwin Sharp 2014-02-16 17:38:43 UTC
No lib64 directory in /usr ?

Linux aptosidbox 3.12-7.slh.2-aptosid-amd64 #1 SMP PREEMPT Tue Jan 14 02:29:37 UTC 2014 x86_64 GNU/Linux