Issue 116992 - Binary blob column does work in table but not in view
Summary: Binary blob column does work in table but not in view
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.3
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2011-02-17 09:02 UTC by xorx
Modified: 2013-01-29 21:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description xorx 2011-02-17 09:02:53 UTC
to reproduce:
Connect to a database (in my case firebird) via jdbc (Jaybird 2.2) from any
client (I tested WindowsXP-Client and mac OS X).
The table must have a column e.g. "IMAGE" of type BLOB sub_type 0 not null.
Create a view on the table showing the blob colum "IMAGE".
Display the table in oo base -> Works fine
Display the view in oo base -> Error message:

  org.firebirdsql.jdbc.FBCachedBlob cannot be cast to org.firebirdsql.jdbc.FBBlob

This problem might be similar to resolved issue #105086

I have checked the connection via JDBC with a small java program and it works
fine for both table and view. So JDBC should not be the reason here.
Comment 1 r4zoli 2011-02-17 15:36:17 UTC
I can confirm it with OOo 3.3 this happens and only with view.

To reproduce it, open file connected to firebird server with JDBC.
add image field to any table with BLOB sub_type 0.

Create form, add any image through form, to table, you can add image without
problem. You can open table without any problem.
Create view select all fields from table, save it. 
When double click on view you get error: 
 org.firebirdsql.jdbc.FBCachedBlob cannot be cast to org.firebirdsql.jdbc.FBBlob

Same happens in DEV300m100.

If I open in cws dba34d version downloadable from qa-upload, if I click on table
the table not opens, give same error message what I get when open view.
Something went wrong in cws dba34c or d with Blobs.

Comment 2 xorx 2011-02-20 19:01:54 UTC
The same error shows up not only with views but also with a query from OO base of the same kind.