Issue 118638 - Query with left or right join fails in 3.3 but worked in 3.2
Summary: Query with left or right join fails in 3.3 but worked in 3.2
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.3
Hardware: PC Windows Vista
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2011-11-24 18:55 UTC by Bill Dornbush
Modified: 2013-01-29 21:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Bill Dornbush 2011-11-24 18:55:39 UTC
I upgraded to 3.3 from 3.2.  I ran a database report based on a query which returned no data but worked fine in 3.2.
The query is:
SELECT "Laptop"."Laptop", "Laptop"."CPCN", "Counselor"."Lname" FROM { OJ "Counselor" AS "Counselor" RIGHT OUTER JOIN "Laptop" AS "Laptop" ON "Counselor"."Laptop" = "Laptop"."Laptop" }

If the right outer join is removed, then the query runs but of course returns only data where both tables contain "laptop"
Comment 1 r4zoli 2011-11-25 08:45:35 UTC
Please check in OOo 3.4Beta.
Lot of bugs were solved during development.

Or can you add an example file to help me check in OOo 3.4Beta.