Issue 120769 - [From Symphony]Color of underline display wrongly
[From Symphony]Color of underline display wrongly
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: editing
3.4.1
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
: usability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 01:55 UTC by Yan Ji
Modified: 2012-10-10 06:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (16.39 KB, application/vnd.oasis.opendocument.text)
2012-08-31 01:55 UTC, Yan Ji
no flags Details
Fix for issue that in sw don't show same color for texts and underline/strikethrough. (844 bytes, application/octet-stream)
2012-09-03 08:18 UTC, kang jane
kangjane2012: review? (chengjh)
Details

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-08-31 01:55:45 UTC
Created attachment 79247 [details]
sample

Build: AOO 3.5 rev. r1377620
OS: All
Steps:
1. New a writer.
2. Input several lines text
3. Select some text across one line, and change the font color
4. Select all text and add underline for them.

Defect: the underline color is not the same as the font color.

Pls refer to the attached sample.
Comment 1 kang jane 2012-09-03 08:18:58 UTC
Created attachment 79278 [details]
Fix for issue that in sw don't show same color for texts and underline/strikethrough.

Root cause:
Don't handle with the underline color for a paragraph with different font color settings when painting. Current it will keep same color with first portion of a paragraph for the other portions.

Solution:
Add the approach to keep the same color for the portions with different font color and their underlines.

UT:
1.Test on a line texts with different font color.
2.Test on several continuous lines with different font color.
3.Test on several continuous lines with same font color.
4.Test on several discontinuous lines with same font color.
Comment 2 Jian Hong Cheng 2012-09-04 07:13:19 UTC
Not only the core function enhanced,but also the interoperability improved...This patch has been reviewed for working well,committed with revision 1380463...thanks for the patch.
Comment 3 Du Jing 2012-09-20 06:49:38 UTC
verified on the build AOO3.5_r1387482
Comment 4 Du Jing 2012-09-20 07:06:39 UTC
verified on the build AOO3.5_r1387482
Comment 5 Shenfeng Liu 2012-10-10 06:44:13 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.