Issue 121507 - Does not read comma as delimiter of parameter in enhanced-path of custom shape
Does not read comma as delimiter of parameter in enhanced-path of custom shape
Product: Draw
Classification: Application
Component: code
PC Windows XP
: P3 Normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
: needmoreinfo
Depends on:
  Show dependency treegraph
Reported: 2012-12-18 23:19 UTC by Regina Henschel
Modified: 2013-07-12 16:33 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Rectangle custom shape with comma delimiter (9.88 KB, application/
2012-12-18 23:19 UTC, Regina Henschel
no flags Details
Error MEssage with OOo 1.1.5 (25.03 KB, image/png)
2013-05-24 05:20 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2012-12-18 23:19:25 UTC
Created attachment 80047 [details]
Rectangle custom shape with comma delimiter

ODF allows commas as parameter delimiter in chapter 19.145, "Parameters may also be delimited by comma characters." AOO does not read it, but gives an empty path. Commas are useful to optically group the parameters in x,y pairs.

The attached document contains such a custom shape with comma as delimiter.
Comment 1 Rainer Bielefeld 2013-05-24 05:20:08 UTC
Created attachment 80724 [details]
Error MEssage with OOo 1.1.5

My skills are very limited here, but due to error message in OOo 1.1.5, what explicitely mentions this "Comma Delimiter Issue", I think I can confirm this one.

All my various OO (2.0 and later) and LibO Versions show an empty page when I open the document, <control+a> selects an invisible rectangle
Comment 2 Rainer Bielefeld 2013-05-24 05:45:11 UTC
Unfortunately none of the ODF 1.2 validators I know currently works, <> states "Valid ODF 1.0" for reporter's sample document.

@Regina Henschel:
How exactly did you create you sample document

I tried folowing (to be honest: without knowing what I did):
In content.xml of my document I replaced
'"M 0 0 L 21600 0 21600 21600 0 21600 0 0 Z N"'
'"M 0,0 L 21600,0 21600,21600 0,21600 Z N"'
what I found in content.xml of your document.
When I reopened the document the Shape still was visible in the modified ODG (with AOO4.0-dev). Is that something relevant or did I simply something wrong?
Comment 3 SVN Robot 2013-05-29 13:10:27 UTC
"alg" committed SVN revision 1487472 into trunk:
i121507 Added commata to whitespace list
Comment 4 Armin Le Grand 2013-05-29 13:10:52 UTC
ALG: Added commata to whitespace list, works, comitting, done.