Issue 124946 - Embedded PNG Pictures replaced by "Read Error" box
Summary: Embedded PNG Pictures replaced by "Read Error" box
Status: VERIFIED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.2.0-dev
Hardware: All Windows 7
: P3 Normal (vote)
Target Milestone: 4.1.1
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 124985 114361
  Show dependency treegraph
 
Reported: 2014-05-21 05:23 UTC by Rainer Bielefeld
Modified: 2014-07-24 04:10 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
Sample Document (193.06 KB, application/vnd.oasis.opendocument.text)
2014-05-21 08:16 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2014-05-21 05:23:08 UTC
I observed the picture loss with "AOO 4.2.0-Dev – German UI / German locale [AOO420m1(Build:9800)  -   Rev. 1595858 2014-05-20 1]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions during my tests to verify fix for "Issue 124717 - Embedded GDI Metafiles replaced by "Read Error" box after File - Save":

I had inserted a detail of a screenshot into a writer table. Waited 1/2 h or so, inserted a detail of a different new screenshot the cell of the table directly below, and after a short moment (i do not remember whether I did some scrolling or similar) the first screenshot was replaced by red error box.

Additional info:
-----------------
(a) Definitively no 'File -> Save' action before the picture became lost,
    Document still has a 2012 date
(b) Some more research with the newly saved document with missing picture
    shows: unzipped document in folder "Pictures" only contains a .png
    for the second screenshot, the first .png for first screenshot is missing
(c) I will try to find a way to make this problem reproducible for further 
    tests.
(d) dependencies and relation to Issue 124717 will have to be checked
(e) As mentioned in Issue 124717 I also observed such a loss problem with
    .jpg pictures inserted from file (but not linked), I can't remember
    precise details. I will check relation to problem with .png.
Comment 1 Oliver-Rainer Wittmann 2014-05-21 06:53:10 UTC
I will try to reproduce this issue.

@Rainer:
Did you insert the screenshots into a new text document or into a existing one?
Comment 2 Rainer Bielefeld 2014-05-21 07:05:36 UTC
(In reply to Oliver-Rainer Wittmann from comment #1)
It was an existing 2012 document with some complex structure similar to the one I sent to you by private mail.
Comment 3 Rainer Bielefeld 2014-05-21 07:19:03 UTC
(f) The screenshot details what became lost were copied from IrfanView.
    Size: rectangle 1/2 screen diagonal
Comment 4 oooforum (fr) 2014-05-21 07:43:39 UTC
A french user has the same problem.
https://forum.openoffice.org/fr/forum/viewtopic.php?f=3&t=43205

Steps to reproduce:
1) open the attached file (2nd post: test.odt)
You can see in page 2, two pictures created with Draw and pasted as GDI in a table.
2) jump to page 1 and input some text
3) save the document
4) go back to page 2, the left picture is gone
Comment 5 Ariel Constenla-Haile 2014-05-21 07:49:40 UTC
(In reply to oooforum from comment #4)
> A french user has the same problem.
> https://forum.openoffice.org/fr/forum/viewtopic.php?f=3&t=43205
> 
> Steps to reproduce:
> 1) open the attached file (2nd post: test.odt)
> You can see in page 2, two pictures created with Draw and pasted as GDI in a
> table.
> 2) jump to page 1 and input some text
> 3) save the document
> 4) go back to page 2, the left picture is gone

This one seems to be Issue 124717
Follow Oliver's advice in Issue 124717 comment 24 (reload the page), and the picture is back.
Comment 6 Rainer Bielefeld 2014-05-21 07:57:23 UTC
(f) Comment 4 is unrelated, GDI has nothing to do with png. This one is 
    concerning a completely different problem. 
(g) The problem is 100% reproducible for me with documents like you will find
    in attachment.
Comment 7 oooforum (fr) 2014-05-21 08:08:27 UTC
(In reply to Ariel Constenla-Haile from comment #5)
> This one seems to be Issue 124717
Well, I didn't see because it has been closed
> Follow Oliver's advice in Issue 124717 comment 24 (reload the page), and the
> picture is back.
I don't understand. This issue is set to fixed status with this workaround?
Comment 8 Ariel Constenla-Haile 2014-05-21 08:16:12 UTC
(In reply to oooforum from comment #7)
> I don't understand. This issue is set to fixed status with this workaround?

No, see Issue 124717 comment 26
That bug is fixed on trunk
Comment 9 Rainer Bielefeld 2014-05-21 08:16:22 UTC
Created attachment 83440 [details]
Sample Document

Steps how to reproduce with "AOO 4.2.0-Dev – German UI / German locale [AOO420m1(Build:9800)  -   Rev. 1595858 2014-05-20 1]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions:

1. From WIN file explorer open sample document with double click, confirm
   update, ignore warnings
2. Into first table ("Muster123") click into Table1.:A10) and insert row
3. Switch to WIN Desktop -> <print> for screenshot -> open IrfanView -> 
   <control+v> for Paste -> Select an area in IrfanViw with similar ratio and
   3/4 diagonal -> menu 'Edit -> Copy'
4. Switch to Writer Document ->  click into Table1.:A10 -> <control+v> for 
   paste
   > Picture appears
5. Wait 20 Minutes
6. In cell below screnshot: click and insert row
7. Wait 20 minutes
8. Redo from step 3 (you also may use the existing secreenshot in IrfanView
   with different detail frame size) and copy/paste from 
   IrfanView into latest created new cell until you will observe
   a "read error" placeholder

Additional Info:
(h) Different to "Issue 124717 - Embedded GDI Metafiles replaced by 
   "Read Error" box after File - Save" a 'File -> Reload' here will not
   help - of course.
Comment 10 Regina Henschel 2014-05-21 09:25:42 UTC
@Rainer: What time do you use in "save AutoRecovery information" and which time in "Graphics cache > Remove from memory after"?
Comment 11 Rainer Bielefeld 2014-05-21 09:46:12 UTC
(In reply to Regina Henschel from comment #10)
With 4.2.0-dev:
Auto recovery info: every 15 minutes
Graphics cache:     9   MB
Memory / Object     2,4 MB
Remove from Memory: 10  Minutes
Cache for           20 objects

With 4.0.1 al the same:
Auto recovery info: every 15 minutes
Graphics cache:     9   MB
Memory / Object     2,4 MB
Remove from Memory: 10  Minutes
Cache for           20 objects

I am just starting a test 4.2.0 - 4.0.1 parallel, identical steps.
Comment 12 Rainer Bielefeld 2014-05-21 10:36:11 UTC
I now did a test with identical copies of my sample document, 1 in version due to report and 1x 4.0.1 WIN server installation, both running parallel
I did all steps every time for both documents.
The waiting times in my comments are only approximately, in my parallel test much longer.
In the 4.2-dev document the problem already was visible after my step 7
No Problem with 4.0.1

Currently only reproduced with 4.2.0-dev, I will also test a 4.1.0 without fix for Issue 124717 (you never know)
Comment 13 Regina Henschel 2014-05-21 10:52:04 UTC
I can reproduce the error with the attached document and given steps using administrative installation and virgin user profile of German version AOO420m1(Build:9800)  -  Rev. 1596218 on Windows 7.
Comment 14 Regina Henschel 2014-05-21 11:18:38 UTC
I see the error too with a new document with table, using steps 2 to 5 and without steps 6 to 8. The picture already disappears after waiting some time. But I have not measured the time yet.
Comment 15 Rainer Bielefeld 2014-05-21 12:53:53 UTC
(k) NOT reproducible with server installation of "AOO 4.1.0-dev – English UI
    / German locale - [AOO410m14(Build:9760)  -  Rev. 1583418 2014-05-03]" 
    on German WIN7 Home Premium (64bit)", own separate user profile.
    So this seems to be a relative new problem
Comment 16 Rainer Bielefeld 2014-05-21 13:05:41 UTC
Comment on attachment 83440 [details]
Sample Document

So my tests for this issue are terminated except someone has a question.
Comment 17 Oliver-Rainer Wittmann 2014-05-22 07:23:22 UTC
I am taking over this issue to work on a solution.
It looks like that my changes for issue 114361 triggers this defect in combination with the automatic save of recovery information.
Comment 18 SVN Robot 2014-05-23 14:34:22 UTC
"orw" committed SVN revision 1597102 into trunk:
124946: only apply new embedded stream name for a graphic, if is already has ...
Comment 19 Oliver-Rainer Wittmann 2014-05-23 14:45:05 UTC
fixed on trunk.

the fix is a correction for the fix of issue 114361. Thus, please verify that issue 114361 is still fixed, when this correction is available in a corresponding build.
Comment 20 Oliver-Rainer Wittmann 2014-06-06 11:49:58 UTC
As issue 114361 is candidate for 4.1.x release and this issue contains needed correction for issue 114361, this issue should also be a candidate for a 4.1.x release
Comment 21 Oliver-Rainer Wittmann 2014-06-16 08:33:19 UTC
requesting release blocker flag as this fix is a necessary correction for the fix of issue 114361
Comment 22 jsc 2014-06-16 08:48:36 UTC
grant showstopper flag, fix available
Comment 23 SVN Robot 2014-06-19 08:42:49 UTC
"orw" committed SVN revision 1603757 into branches/AOO410:
124946: only apply new embedded stream name for a graphic, if is already has ...
Comment 24 Oliver-Rainer Wittmann 2014-06-19 08:44:27 UTC
fixed on branch AOO410 for planned 4.1.1 release
Comment 25 Shenfeng Liu 2014-07-07 06:53:03 UTC
Can not reproduce this defect using AOO 4.1.1 milestone build 1, following the description.
But per the comment #17, the defect should be reproduced using trunk build post 4.1, between revision 1595847 and revision 1597102. Unfortunately such old build is no long being able to be found in Buildbot.
So I suggest reporter or who reproduced this defect before to verify this defect with AOO 4.1.1 milestone build.
Thanks!
Comment 26 fanyuzhen 2014-07-08 10:16:51 UTC
Rainer Bielefeld and Regina Henschel, could one of you please verify this defect on AOO 4.1.1? Thanks!
Comment 27 Pedro 2014-07-19 09:13:27 UTC
Could not reproduce the error with AOO411m2(Build:9771)  -  Rev. 1608452 under Windows 7 SP1 x64.
Apparently the bug is fixed.
Comment 28 fanyuzhen 2014-07-24 04:10:20 UTC
Thanks Pedro and Simon, I mark it as Verified / Fixed based on check results in comment 25 and 27.