Issue 125000 - CRASH when scroll through very large and complex .odt
Summary: CRASH when scroll through very large and complex .odt
Status: VERIFIED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 4.1.0
Hardware: All Windows 7
: P2 Major (vote)
Target Milestone: 4.1.1
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords: regression
: 124994 (view as issue list)
Depends on: 124999
Blocks: 124985
  Show dependency treegraph
 
Reported: 2014-05-28 06:08 UTC by Rainer Bielefeld
Modified: 2014-08-03 18:04 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2014-05-28 06:08:10 UTC
Steps how to reproduce with "AOO 4.2.0-Dev – German UI / German locale [AOO420m1(Build:9800)  -   Rev. 1597166  2014-05-20 1]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions: Proceed as per "Issue 124999 - Huge memory consumption for very large and complex .odt"

0. Launch WIN Task Manager
1. Download / Unzip test kit "Issue 118725 Comment 13 - images dropped by random"
2. Open "TestBook2.odt" (140MB document), watch memory consumption
   > 1,7 GB or so for opening document
3. Click into first page, then pres downpage key and keep pressed
   slowly increasing memory consumption (nearby invisible), CRASH after few pages


Additional Info: 
(a) already Reproducible with server installation of "AOO 4.1.0-Dev – 
    English UI / English locale - [AOO410m1(Build:9750) - Rev. 1537973 - 
    2013-11-03]" on German WIN7 Home Premium (64bit)", 
    own separate user profile.

(b) No crash with server installation of "AOO 4.1.0-Dev – English UI 
    / German locale - [AOO410m1(Build:9750) - Rev. 1536316 - 2013-10-30]" 
    on German WIN7 Home Premium (64bit)", own separate user profile.
Comment 1 Rainer Bielefeld 2014-05-28 06:17:52 UTC
With "AOO 4.2.0-Dev – German UI / German locale [AOO420m1(Build:9800)  -   Rev. 1597166  2014-05-20 1]" I can also reproduce the crash with TestbookWithLotsOfImages.odt, but not with Test4.odt
Comment 2 Rainer Bielefeld 2014-05-28 07:03:09 UTC
*** Issue 124994 has been marked as a duplicate of this issue. ***
Comment 3 Matthias Basler 2014-05-28 16:59:15 UTC
I set this to CONFIRMED, because Rainer essentially confirmed my issue 124994, which is now marked as duplicate. (I checked on Win7 64Bit and 8GB memory, with AOO 4.1.0 release) If you disagree you may change it back.


P.S.
I can really recommend to have a look at how LibreOffice fixed this (these) bugs, because I reported them there too and got them fixed half a year ago or so.

See here:
https://bugs.freedesktop.org/show_bug.cgi?id=73300
(contains the commit infos)

(LO and AOO can only grow on every bit of knowledge transfer between the two ihmo.)
Comment 4 Oliver-Rainer Wittmann 2014-06-04 07:43:19 UTC
I can confirm the crash with AOO 4.1.0 on my Windows 7 system.
With AOO 4.0.1 I had no crash, but similar memory consumption.

I had no problem with document "Test4.odt".
Opening document "TestbookWithLotsOfImages.odt" immediately after the loading process on my Windows 7 with AOO 4.1.0
Comment 5 hdu@apache.org 2014-06-04 09:53:54 UTC
*** Issue 124999 has been marked as a duplicate of this issue. ***
Comment 6 Oliver-Rainer Wittmann 2014-06-05 11:52:35 UTC
taking over to have a closer look
Comment 7 Oliver-Rainer Wittmann 2014-06-06 09:29:04 UTC
Investigation reveals that due to the high memory consumption - issue 124999 - the crash is caused.
Comment 8 Oliver-Rainer Wittmann 2014-06-06 11:43:46 UTC
fix in progress
Comment 9 SVN Robot 2014-06-06 12:27:58 UTC
"orw" committed SVN revision 1600861 into trunk:
125000: <WinSalBitmap::ImplCreateGdiPlusBitmap()> - check last status of newl...
Comment 10 Oliver-Rainer Wittmann 2014-06-06 13:52:02 UTC
fixed on trunk together with the changes made for issue 124999
Comment 11 jsc 2014-06-16 09:09:42 UTC
grant showstopper flag, regression and already fixed
Comment 12 SVN Robot 2014-06-19 09:55:52 UTC
"orw" committed SVN revision 1603801 into branches/AOO410:
125000: <WinSalBitmap::ImplCreateGdiPlusBitmap()> - check last status of newl...
Comment 13 Oliver-Rainer Wittmann 2014-06-19 09:58:27 UTC
fixed on branch AOO410 for planned 4.1.1 release
Comment 14 fanyuzhen 2014-07-08 09:03:01 UTC
It's verified fixed in AOO411m1(Build:9770)  -  Rev. 1603804
2014-06-16 14:10:45 (Mo, 16 Jun 2014) on Win7, no crash in this build.
Comment 15 Pedro 2014-08-03 18:04:46 UTC
There is no crash with AOO411m4(Build:9774)  -  Rev. 1614049 (aka RC1) running on Win7 x64.

The bug seems to be fixed.