Issue 125218 - calc slow saving in xls
Summary: calc slow saving in xls
Alias: None
Product: Calc
Classification: Application
Component: save-export (show other issues)
Version: 4.1.0
Hardware: Mac OS X 10.8
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2014-07-07 21:10 UTC by Eric Gunderson
Modified: 2015-05-01 20:52 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Spreadsheet with formatting that causes a slow save. (347.00 KB, application/
2014-07-10 01:48 UTC, Eric Gunderson
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Eric Gunderson 2014-07-07 21:10:41 UTC
Since updating from 4.0.1 to 4.1.0, the time to save certain XLS documents has increased from a few seconds to a few (3 to 20) minutes.

This may be a bug that was reintroduced, please look at ISSUE ID 122827. I had this same problem in 4.0.0. It was fixed in 4.0.1.

The problem file is 558KB, it has some simple cell calculations, and multiple sheets.

Non-problem files are 100KB or less and have few if any cell calculations or contain single sheets.

To reproduce the problem please download the attachment from ISSUE 122827.
Add a cell value.
Save the document.
The save time for this document was in the 90 to 120 seconds range. 
I expect most saves to take less than 10 seconds.

MacBook Pro
2.2 GHz Intel Core 2 Duo
OS X 10.8.5

Comment 1 Armin Le Grand 2014-07-09 12:11:13 UTC
File is: 2013 Market Accounting.xls, checked on Win version, could not reproduce the problem:

7s on AOO420 (with debug)
1s on AOO411 pro

Tried on mac with AOO411 pro, the same -> very fast.
Tried also on mac with AOO410 debug -> also very fast.

Could not reproduce.
Comment 2 Eric Gunderson 2014-07-10 01:48:39 UTC
Created attachment 83668 [details]
Spreadsheet with formatting that causes a slow save.
Comment 3 Eric Gunderson 2014-07-10 01:49:48 UTC
This document took ~20 minutes to save.
Comment 4 Eric Gunderson 2014-07-10 02:12:08 UTC
I'm running:
AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-15 11:15:48 (Tue, 15 Apr 2014)

I checked the source code for the files in this revision (

I noticed this comment in the source.
// Loop backwards from the end instead of using Search, assuming that
// there usually aren't many attributes below the last cell.

This got me thinking that maybe my problem has to do with the formatting of the cells. So I selected all the cells and did default formatting on all my sheets. This fixed my problem spreadsheets so that they would save quickly.

I've created a new spreadsheet (and attached it here) that took close to 20 minutes to save.
I simply created a new document and the only formatting I added was to make the first column as a "Date". The other columns were given background colors.

As you duplicate the sheet the save time will get worse and worse.

With only 3 sheets it took about one minute.

With 40 sheets it took 20 minutes.

I should also mention that the memory usage goes way up when saving occurs, and slows down the whole computer.
Comment 5 Armin Le Grand 2014-07-10 09:50:07 UTC
Tried with the attachment from comment 2, loaded in Win pro version of AOO411. Changed (added a word in one empty cell) save as -> one second.
Maybe I am doing the wrong change? What *exactly* do I have to change to get a slow save? Should I already get one by
- load SlowSave.xls
- save as changed filename
...? Still cannot reproduce.
Comment 6 Eric Gunderson 2014-07-12 00:15:48 UTC
Yeah, you should be able to make any edit to the spreadsheet and save it, then the problem occurs.

I tried it out on a Windows Vista running AOO4.1.0. But I could not reproduce.

I just tried uninstalling and reinstalling AOO4.1.0 on the Mac OS X 10.8.5. It's still saving slow.
Comment 7 oooforum (fr) 2014-07-15 09:17:01 UTC
(In reply to Eric Gunderson from comment #6)
> I just tried uninstalling and reinstalling AOO4.1.0 on the Mac OS X 10.8.5.
Did you reset your profile between this 2 steps?
Comment 8 Eric Gunderson 2014-07-15 18:22:56 UTC
(In reply to oooforum from comment #7)
> > I just tried uninstalling and reinstalling AOO4.1.0 on the Mac OS X 10.8.5.
> Did you reset your profile between this 2 steps?

Yes, I think so. I removed what I could find in the /Users/{account}/Library/ in regards to OpenOffice.

I removed the following.
Library/Application Support/OpenOffice
Library/Application Support/

I also removed a folder "org.openoffice.script", but I can't remember where it was in the Library structure.

I removed all of that before reinstalling AOO4.1.0.

Will that reset the profile?
Comment 9 oooforum (fr) 2014-07-16 07:21:44 UTC
(In reply to Eric Gunderson from comment #8)
> Will that reset the profile?
Read this:

You should take your questions to our support forum. They can help you. 

The Bugzilla system is for reporting specific, detailed, reproducible bugs that developers can investigate and fix.
Comment 10 Terry N. 2015-05-01 20:47:49 UTC
I was also been facing this issue on 4.0.0 and it was fixed in 4.0.1, but since 4.1.x it is back, and still impacting me on 4.1.1. I'm running Mac OSX 10.7.5 and saving spreadsheets in XLS format with a few formulas and about 10-15 tabs.

Thanks for any help you can offer.
Comment 11 Terry N. 2015-05-01 20:52:17 UTC
One other comment: I was able to reproduce the problem with the slowsave.xls file attached to this issue.