Issue 126006 - Crash when insert pdf OLE
Summary: Crash when insert pdf OLE
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: 4.2.0-dev
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: regression
Depends on:
Reported: 2015-01-05 14:19 UTC by Regina Henschel
Modified: 2015-01-12 16:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

The tested pdf (885.48 KB, application/x-download)
2015-01-05 15:31 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2015-01-05 14:19:50 UTC
Start a new presentation with an empty slide layout.
Insert > Object > OLE Object
Select "Further objects". Click OK. You get a OS dependent dialog.
Select "From file" (or similar wording), click "Browse" (or similar wording), select a .pdf file. OK.

Try same with AOO 4.1.1. There is no problem; Acrobat PDF Reader opens and after exit this reader, OLE is inserted in slide.
Comment 1 Rainer Bielefeld 2015-01-05 14:49:26 UTC
NOT Reproducible with WIN7  German AOO420m1(Build:9800)  -  Rev. 1643177 and AR 11.0.10
May be problem appeared later or related to particular PDF documents or AR or whatever else??
Comment 2 Oliver Brinzing 2015-01-05 15:23:04 UTC
NOT Reproducible with WIN7  German AOO420m1(Build:9800)  -  Rev. 1648122

Could you please add the *.pdf?
Comment 3 Regina Henschel 2015-01-05 15:31:23 UTC
Created attachment 84376 [details]
The tested pdf

That is the pdf file, which I tried to include as OLE into a slide.
Comment 4 Oliver Brinzing 2015-01-05 15:51:01 UTC
cannot confirm with attached *.pdf, 
pdf opens with my acrobat standard 10.1.13
Comment 5 Rainer Bielefeld 2015-01-12 15:56:28 UTC
Reproducible with WIN7  German AOO420m1(Build:9800)  -  Rev. 1643177 and AR 11.0.10 if I rename existing User profile before launch AOO, so that a new user Profile will be created. My user profile definition in bootstrap.ini: "UserInstallation=$ORIGIN/../Data/settings". Worked fine with older existing user profile (see Comment 1). Switching back to my normal user profile healed the crash.
Comment 6 Rainer Bielefeld 2015-01-12 16:04:52 UTC
Still REPRODUCIBLE with German AOO420m1(Build:9800)  -  Rev. 1651021 on WIN7 64bit with any PDF I tested as per comment above only with fresh new userprofile, no crash when I tried same build with existing user profild. Seems not to be related to any other conditions (Hardware acceleration, watever).