Issue 128315 - wrong icon for OLE objects in two places
Summary: wrong icon for OLE objects in two places
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 4.1.7
Hardware: PC All
: P5 (lowest) Minor (vote)
Target Milestone: 4.1.9
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-03 11:41 UTC by Czesław Wolański
Modified: 2020-12-27 10:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.8
Developer Difficulty: ---


Attachments
AOO Writer - screenshot (220.12 KB, image/jpeg)
2020-03-03 11:41 UTC, Czesław Wolański
no flags Details
AOO Draw - screenshot (211.08 KB, image/jpeg)
2020-03-03 11:45 UTC, Czesław Wolański
no flags Details
Navigator (Writer) with changed icon for OLE objects (32.70 KB, image/png)
2020-03-04 17:45 UTC, Matthias Seidel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Czesław Wolański 2020-03-03 11:41:45 UTC
Created attachment 86873 [details]
AOO Writer - screenshot

Initially I thought that my report would be a duplicate of Issue 61805 - wrong icon in toolbar insert, but it turned out it is not. As of now Insert toolbar displays a set of proper icons.

In attached file "Writer" you will see screenshot from AOO Writer showing:
- submenu Insert > Object
- Insert toolbar
- Navigation toolbar
- sidebar, Navigator deck selected

First look at icons in submenu Object for items: "OLE object" & "Charts" (on the left). Same icons you will see in Insert toolbar.
Now notice what icon is shown for OLE object in: Navigation toolbar
and Navigator deck in sidebar. That icon belongs to "Chart".

This situation doesn't not occur in e.g. AOO Draw (see attached file "Draw").
Comment 1 Czesław Wolański 2020-03-03 11:45:21 UTC
Created attachment 86874 [details]
AOO Draw - screenshot
Comment 2 Matthias Seidel 2020-03-03 12:12:10 UTC
Confirmed with AOO 4.1.7 on Ubuntu.
Comment 3 Matthias Seidel 2020-03-04 17:44:22 UTC
OLE-Objects are objects as well as Charts and Formulas...

But I agree that the OLE icon definitely fits better than the Chart icon for the Navigator (see attachment)
Comment 4 Matthias Seidel 2020-03-04 17:45:29 UTC
Created attachment 86879 [details]
Navigator (Writer) with changed icon for OLE objects
Comment 5 Czesław Wolański 2020-03-04 17:59:54 UTC
(In reply to Matthias Seidel from comment #4)
> Created attachment 86879 [details]
> Navigator (Writer) with changed icon for OLE objects

OLE icon - ¡Olé! (in Spanish).

Thanks!
Comment 6 Matthias Seidel 2020-03-04 18:20:16 UTC
Committed to trunk with:

https://github.com/apache/openoffice/commit/8c49b8ba198a843f39601ec483fe7a3d4bfc2504

And Cherry-Picked for AOO42X
Comment 7 Matthias Seidel 2020-12-27 10:38:42 UTC
Committed to AOO419 with:

https://github.com/apache/openoffice/commit/1427dd487af34379101841ed27665dde5975f032