Issue 128415 - Opening a .docx crash on macOS 11.0.1 Big Sur
Summary: Opening a .docx crash on macOS 11.0.1 Big Sur
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.8
Hardware: Mac macOS 11.0
: P5 (lowest) Normal with 4 votes (vote)
Target Milestone: 4.1.9
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp
: 128418 (view as issue list)
Depends on:
Blocks:
 
Reported: 2020-11-26 20:43 UTC by tintin60
Modified: 2021-01-19 18:47 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
mseidel: 4.1.9_release_blocker+


Attachments
This test file crashes AOO (10.37 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-11-26 20:43 UTC, tintin60
no flags Details
crash report (179.76 KB, image/png)
2020-11-26 20:48 UTC, tintin60
no flags Details
crash report (1.67 KB, text/plain)
2020-11-26 21:41 UTC, tintin60
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tintin60 2020-11-26 20:43:54 UTC
Created attachment 86988 [details]
This test file crashes AOO

Hi,

After upgrade from Catalina to macOS Big Sur users on french forum (https://forum.openoffice.org/fr/forum/viewtopic.php?f=3&t=63179) report that the .docx documents (but also .xlsx) cannot be opened with OpenOffice 4.1.8.

Whatever the opening process, OpenOffice crashes.

Fortunately, a workaround is possible using LibreOffice.

NOTA : It works only with .doc files.

I can't test by my own because my Mac is still running Catalina but this is confirmed by a friend of mine who did it for me .

Tanks
Regards
Comment 1 tintin60 2020-11-26 20:48:11 UTC
Created attachment 86989 [details]
crash report
Comment 2 Matthias Seidel 2020-11-26 20:54:16 UTC
(In reply to tintin60 from comment #1)
> Created attachment 86989 [details]
> crash report

Would it be possible to copy the text from the crash report into a text file?
Comment 3 tintin60 2020-11-26 21:41:43 UTC
Created attachment 86990 [details]
crash report
Comment 4 Keith N. McKenna 2020-12-06 19:03:08 UTC
*** Issue 128418 has been marked as a duplicate of this issue. ***
Comment 5 Keith N. McKenna 2020-12-06 19:09:55 UTC
Cannot confirm with the following:
System Configuration:
Processor: Intel  Pentium CPU 4450U @2.10GHz
Installed Memory: 8.00 GB
System Type 64-bit Operating System X64-based processor
Operating System: Windows 10 Version 2004 (OS Build 19041.630)

Apache Open Office
AOO418m3(Build:9803)  -  Rev. 18848f57b6 2020-10-29 16:56
Language: en_US
Additional Language Packs: None

Need a volunteer with a mac to try to confirm this.
Comment 6 oooforum (fr) 2020-12-15 10:24:18 UTC
Confirmed on french forum that Big Sur is only concerned by this bug.

Confirmed too that 4.2.0-dev has no problem.
Comment 7 Jim Jagielski 2020-12-27 16:00:38 UTC
Backporting UNO fixes for macOS from AOO42X seems to address this issue. 4.1.9 is expected to close this.
Comment 8 Keith N. McKenna 2021-01-02 16:00:52 UTC
Confirmed fixed by various users from the French Community
Comment 9 tintin60 2021-01-04 18:16:25 UTC
Hi guys,

I was able to get a .docx file

New French test version available here : http://home.apache.org/~jim/AOO-builds/Dev/fr/Apache_OpenOffice-Dev_AOO419m1_MacOS_x86-64_install_fr.dmg

Step 1 : I installed it > _AOO-Developer-Build.app (By the way, it is always  necessary to surpass the Gatekeeper).

NB : As usually in that case, the installation creates a special profile called AOO-Developer-Build.

This .docx file opened normally with this special profile.

Step 2 : I transferred the content of my usual profile into the special profile and restarted AOO-Developer-Build.app.

The .docx file opened normally.

For me it is OK.

Congratulations for the speed and thanks to the developers.

Best regards
Comment 10 tintin60 2021-01-04 19:31:05 UTC
Of course, you have understood my MacBook Pro is now running macOS 11.1 Big Sur
Comment 11 dle 2021-01-15 14:50:09 UTC
Hi,

I also confirm, that AOO419 corrects the issue on docx. Tests carried out only on this type of documents.
Congradulations

Regards
Comment 12 Matthias Seidel 2021-01-15 15:49:59 UTC
Did anyone test documents other than docx?

I understood that the crash occurred with all OOXML?
Comment 13 tintin60 2021-01-15 17:10:31 UTC
Hi,

AOO-Developer-Build.app : no malfunction with .odt, .ods, .odp, .odg and odb files on my Mac (Product Version: 11.1  Build Version: 20C69)

No change about Issue 127646 Test version Base crashes with macro autoexec
Comment 14 Matthias Seidel 2021-01-15 17:23:15 UTC
Thanks,

But what about OOXML documents like xlsx, pptx and so on?
Comment 15 tintin60 2021-01-19 18:47:21 UTC
Hi,

I installed this version 4.1.9

https://dist.apache.org/repos/dist/dev/openoffice/4.1.9-RC1/

(with my usual profile).

No problem to open .docx documents.
Unfortunately I don't have any .xlsx or .pptx to test.

Sorry for the Dev's but thanks for your work.