Issue 16158 - Macro: Changes in dialog Format/Page are not recorded
Summary: Macro: Changes in dialog Format/Page are not recorded
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 Beta2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Blocks: 81517
  Show dependency tree
Reported: 2003-06-27 15:03 UTC by helmerj
Modified: 2017-05-20 11:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description helmerj 2003-06-27 15:03:30 UTC
When I use the macro recorder to record the reformating of a page in writer 
(or an object in draw), it record the opening of the formating dialog (e.g. 
Format> Page) but it does not record the choices made in the dialog itself 
(like chnaing the Format of th epage rom A4 to letter). Running the macro 
opens the dialog just fine but that's it. 
Same happens in draw, when I try to chnage the property of a text box from 
"adjust width to text" to "adjust to frame". The dialog pops up but it doesn't 
do the requested changes. 
OO1.1b2 on Mandrake Linux 9.1 
Comment 1 helmerj 2003-06-27 15:38:22 UTC
The same problem exist using OO1.1b2 on Win98. 
Comment 2 noel.power 2003-06-30 11:44:24 UTC
Hi Mathias,
Don't know what component this should be against do you? sounds like
another area where options not picked up by macro recorder :-(
Comment 3 Mathias_Bauer 2003-06-30 14:10:38 UTC
There is no macro recorder in Draw, so in Draw there is no issue.
The writer dialog is - of course :-) - a problem in writer. 

Comment 4 Mathias_Bauer 2003-07-02 16:44:26 UTC
This is a Writer issue
Comment 5 Mathias_Bauer 2003-07-03 09:57:12 UTC
Comment 6 Oliver Specht 2003-07-03 11:02:00 UTC
Component, platform, OS and Component changed
Comment 7 Oliver Specht 2003-07-04 08:43:27 UTC
Comment 8 Oliver Specht 2003-08-29 10:37:16 UTC
Title changed.
Comment 9 Oliver Specht 2003-10-06 12:42:47 UTC
Comment 10 stefan.baltzer 2003-10-07 10:43:15 UTC
SBA: According to the roadmap this issue was retargeted to "OOo
Comment 11 tlyczko 2004-03-30 23:09:25 UTC
Almost a year later, and this bug is *still* not fixed.

This is a deal-breaker for me, I can't recommend this software to anyone as a 
result of something so basic not functioning properly.

Not to mention that OOo crashed 5 times during the first 10 minutes that I 
tried to use it.

I'll probably be uninstalling OOo pretty soon.

Oh...WinXP SP1, OOo 1.1.1, quite recent JVM.

Thank you,
:) tom
Comment 12 nasser_n 2006-01-26 01:51:10 UTC
This bug was reproduces under widows XP 2.0 (2.0) and also under FC4 2.0 (1.9.125)
It seems that macro recorder does not preserve any operations that involves 
using the mouse.
The following case were tried using mouse (only) and keyboard (only):  

Test #1:

1.Open Tools menu and choose record macro.
2.Select writer window and type something.
3.Using mouse select a section (or all) of the typed text.
4.Using mouse open the font colour chooser and change the colour.
5.Stop the macro recording and save your macro.
6.Open the saved macro.

When the saved macro is opened is it observed that font colour has not changed 
and is black.
If you follow the same procedure and change the font-face, size and style 
using mouse you will see that the same thing happens (the font-face, size and 
style are not preserved in the saved version).
Now if you do all the above procedures but use the keyboard for selection 
(shift+arrow keys) you will see that the recorder records all the changes and  
in the recorded version you could see different colours, font-faces, etc.

A very similar case happens if you change the caret position using mouse, that 
is if in the writer page, while recording macro, you type something in the 
first line, say  “This†and then go to the second line and type “is a†and 
then go back to first line using the mouse and type “bug†and save the macro. 
In the save version you will see “This†in the first line and “is a bug†in 
the second line. But if you do the same thing using arrow keys you will 
see “This bug†in the first line and “is a†in the second line, as expected.
Comment 13 Mathias_Bauer 2006-11-13 11:19:20 UTC
Comment 14 Marcus 2017-05-20 11:21:45 UTC
Reset assigne to the default "".