Issue 16937 - Soundeffects get lost
Summary: Soundeffects get lost
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 RC
Hardware: Other All
: P3 Trivial with 22 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
: 87956 102131 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-07-16 10:49 UTC by powa
Modified: 2017-05-20 11:08 UTC (History)
4 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description powa 2003-07-16 10:49:01 UTC
The soundeffects get lost when you copy a presentation to another destination 
for example cp xxx.sxi to another folder
Comment 1 wolframgarten 2003-07-17 08:34:45 UTC
Reassigned to Christian.
Comment 2 christian.guenther 2003-07-18 12:03:30 UTC
set to new
Comment 3 christian.guenther 2003-07-18 12:07:15 UTC
This is a known bug which will be fixed in one of the next versions.
Comment 4 bettina.haberer 2003-07-18 12:58:17 UTC
BH->CGU: As I'm not a recipient of bugs, I reassign this bug back to
you. Please keep this one, and check the bugfix in the according version.
Comment 5 bettina.haberer 2003-07-18 13:15:35 UTC
Issue Type corrected.
BH->CGU: Please always make a comment, if you change a status!
Comment 6 christian.guenther 2003-07-21 10:19:25 UTC
Hi Christian,

I know that you are already working on this bug/feature.
Please handle this issue when you've finished this bug/feature or set
this issue to duplicate if another bug already exist.
Comment 7 clippka 2003-07-21 12:46:38 UTC
we don't embed sounds in our documents and this feature is not planed yet
Comment 8 christian.guenther 2003-07-22 09:55:00 UTC
Hi bettina,

according to the comment of CL this is not a bug but a missing feature.
Please handle this feature request.
Comment 9 christian.guenther 2008-04-11 21:06:37 UTC
*** Issue 87956 has been marked as a duplicate of this issue. ***
Comment 10 christian.guenther 2008-04-14 09:55:24 UTC
Change the target.
We should embed the sound in the document.
Comment 11 wolframgarten 2009-05-25 10:38:44 UTC
*** Issue 102131 has been marked as a duplicate of this issue. ***
Comment 12 gmolleda 2009-05-25 14:15:58 UTC
A possible solution is change the source code for load and save menu functions.
Create a directory Sounds or Video&Sounds in internal structure of file .odp
(same as directory images).

Is very bad the actual behavior, when you open a ppt or pps file with music and
save as odp, you believe all is ok (the music play well) and e-mail the odp file
to friends. They haven't hear the music because OpenOffice saved the music to my
local directory ".../openoffice.org2/user/gallery" in a non-transparent to the
user misleading.
Comment 13 Rainer Bielefeld 2009-08-27 14:22:38 UTC
I believe there is no need to embed sounds, we only need something like a
relative link like ".../OOo_sound_gallery/mysoundeffect/" instead of a static
link to the sounds. Pls see Issue 76305!
Comment 14 gmolleda 2009-08-27 15:09:34 UTC
Why you believe that isn't there embed sounds?

I want that if I create a presentation, with sounds and videos, and I save the
presentation in a file .odp, when I send this file to other people, they can
view and hear all original presentation.

The file .odp must to hear when I send the presentation by e-mail.

If you did't embed the sound and video, How you get hear the sounds with the
file .odp?
Comment 15 clippka 2009-11-18 13:04:28 UTC
started work on embedding sounds&video in odf documents in cws impressmedia01.
My current plan is to finish this until OOo 3.3
Comment 16 gmolleda 2009-11-18 14:18:34 UTC
Suggestions:

Put a option, in Tools-Options - OpenOffice.org impress, with max size files
embedded, if the file size (audio, video, ...) > max size then files go in
external files. If file size <= max, then embed file in presentation file .odp

Default options could be 5 or 10 MB, but the user could up it depends of speed
Internet or other things.
Comment 17 jumperger 2009-11-20 18:05:03 UTC
odp saved without embedded sounds (used sounds saved localy), then saved as ppt 
(without embedded sounds).
ppt opened with powerpoint, sound embedded with powerpoint, saved as ppt
ppt (containing embedded sound) opened with Impress and saved as .odp
odp DOES NOT contain embedded sound now. Sound files were copied 
to /../Library/Application Support/OpenOffice.org/3/user/gallery/ and work, but 
when sending the .odp by email you do not get any sound during presentation.
Comment 18 gmolleda 2009-11-20 22:19:58 UTC
Yes Jumperger, but the objetive is not use propietary formats.

We want to have a open format that work, and send the files in format
OpenDocument for to doing visible the format and OpenOffice to all people.

If you send files in ppt format you are doing marketing and promotion for M$ Office.

Thanks for your solution, it is ok while OoO don't embed media files.
Comment 19 tintin60 2010-05-06 09:18:55 UTC
2010/05/06 OOo.org 3.2. Still waiting for improvment.
Comment 20 tintin60 2010-05-07 09:25:25 UTC
OOo.org 3.2 Still waiting for improvment
Comment 21 jbf.faure 2010-06-05 16:23:28 UTC
Add me to cc.
Comment 22 Marcus 2017-05-20 11:08:55 UTC
Reset assigne to the default "issues@openoffice.apache.org".