Issue 20088 - Does Not Detect Mozilla Thunderbird Address Book
Summary: Does Not Detect Mozilla Thunderbird Address Book
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC5
Hardware: PC All
: P3 Trivial with 42 votes (vote)
Target Milestone: OOo 2.0
Assignee: marc.neumann
QA Contact: issues@dba
: 42341 (view as issue list)
Depends on:
Blocks: 48725
  Show dependency tree
Reported: 2003-09-25 18:04 UTC by Unknown
Modified: 2006-05-31 14:29 UTC (History)
7 users (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-09-25 18:04:33 UTC
Tools | Data Sources | Data Source Administration cannot find the Mozilla
Thunderbird Address Book. An error alert that says in part "No connection could
be established..." results.

The Mozilla browser suite stores its address book (abook.mab) within a folder
called Mozilla. The Thunderbird address book (also abook.mab) is stored within a
folder called Thunderbird.
Comment 1 marc.neumann 2003-09-26 11:12:02 UTC
confirm, set target, change defect to enhancement and send to right
Comment 2 ridcully 2003-09-29 09:25:47 UTC
same Problem with Linux.
abook.mab location: /home/ridcully/.thunderbird/2353473.slt/abook.mab
Comment 3 2003-10-16 02:55:59 UTC
You can add these lines to your prefs.js to make your mozilla 1.0 to
support thunderbird address book in windows os(remomeber use right
count of "..\\"):
user_pref("ldap_2.servers.thunderbird.description", "Thundbird Address
user_pref("ldap_2.servers.thunderbird.dirType", 2);
"..\\..\\..\\..\\..\\..\\..\\Your ThunderBird Profiles Path\\abook.mab");
user_pref("ldap_2.servers.thunderbird.isOffline", false);
user_pref("ldap_2.servers.thunderbird.position", 10);
user_pref("ldap_2.servers.thunderbird.replication.lastChangeNumber", 0);

Maybe we can use this way to access thunderbird address in OOo.
Comment 4 hans_werner67 2004-02-02 12:54:27 UTC
change subcomponent to 'none'
Comment 5 2004-02-10 06:20:33 UTC
Migrate to a new account for security reasons.
Comment 6 sforbes 2004-05-01 10:41:34 UTC
changing OS to "ALL" as this is a linux issue as well.
Comment 7 2004-12-03 10:22:27 UTC
in cws mozab05
Comment 8 catatized 2004-12-03 22:12:16 UTC
Also would it be possible for OpenOffice to see the address book used in
Comment 9 Frank Schönheit 2004-12-06 08:45:56 UTC - feel
free to submit a issue dedicated to incredimail support.
Comment 10 2005-01-31 14:31:55 UTC
fixed in mozab05
Comment 11 2005-02-01 10:05:06 UTC
reopen to reassign
Comment 12 2005-02-01 10:07:38 UTC
assign to qa
Comment 13 2005-02-01 10:08:42 UTC
fixed in CWS mozab05
Comment 14 Frank Schönheit 2005-02-09 15:27:35 UTC
*** Issue 42341 has been marked as a duplicate of this issue. ***
Comment 15 marc.neumann 2005-02-18 08:26:11 UTC

verified in cws mozab05

Bye Marc
Comment 16 wernerm 2005-03-04 13:14:58 UTC
OOo 2 Beta (1.9.79) still doesn't seem to work with the addressbook of
Thunderbird. I'm a bit confused, because the issue is marked as "fixed". Will it
work in 00o 2 final? Or am I the only one who still runs into this problem? 
Comment 18 matthiasotto 2005-03-26 14:15:39 UTC
OOo 2 Beta (1.9.87) still doesn't seem to work with the addressbook of
Thunderbird. I can choose the Mozilla Thunderbird Adressbook as Database source,
but i can't do any Field assignment.

Am I the only one who still runs into this problem? 

Comment 19 fasse 2005-03-26 16:58:50 UTC
No, you aren't. The addressbook-assistant of OpenOffice 2 Beta didn't find my
Thunderbird Adressbooks when I choose Mozilla-Addressbook and I'm not able to
choose a path for the addressbook.
Comment 20 pancapangrawit 2005-03-26 18:38:28 UTC
fasse, you can explicitely choose Thunderbird Addressbook now under external
data-sources, I think that is what mathiasotto did. Yes, Mathias, it's also
buggy for me, no field-assignment possible and no database-file gets saved. If
you are looking for a workaround (rather than just report the bug): for me it's
possible to register the thunderbird-addressbook as a general type of external
data-source (rather than "the" address-source). Once you saved a database-file
for that, you can point the address-book wizard to the allready existing
database-file. After that, when you use the mail-merge wizard, you can assign
Comment 21 marc.neumann 2005-04-07 10:16:31 UTC

fixed in current developer build ( tested m91 ) -> close.
The current developer build can be found at
Feel free to reopen if this issue is not fixed in the developer build.

Bye Marc
Comment 22 superbiskit 2005-04-07 20:16:20 UTC
I hate to be picky, but isn't it premature to advertised 'CLOSED' when the cited
build isn't yet up on the mirrors?  
You say 'fixed in m91' however only m87 is available as of this date/time.

OK, no I don't really hate being picky.
Comment 23 pancapangrawit 2005-04-12 22:28:55 UTC
Hi, I checked m91, something changed, it's close to o.k. now, but still with
little problems. Maybe it's a bug in the 'Address-book data-source-WIZARD' now -
that's where I tried it the first time. I could select a profile, fine. As to
the table I selected after that (out of my 3 thunderbird-address-tables) a) I
couldn't do field-assignment the first time b) it didn't stick (when I later ran
the mail-merge-wizard no address-table was preselected) and c) I use German Ooo:
my address-book is called Persönliches Adreßbuch - the Umlaut ö and 'ß' are
represented as '('.
So after adding the necessary selections in mail-merge-wizard everything works
and sticks. Only the cosmetical ö=( issue remains.
Comment 24 Frank Schönheit 2005-04-13 07:37:05 UTC
could you please file separate issues for the problems which you are still
encounter? They do not really fit in here, since this is about general support
of Thunderbird. Thanks :)
Comment 25 gonzalez 2005-07-24 23:44:25 UTC
I am working with OOo 1.9.121. I still can'make connection with Thunderbird (as
was also the case with ALL previous builds and versions).I think the "defect"
has not been "enhanced". Can this be fixed (again?), please?
I'd simply like to use within OOo any of the many Thunderbird Address books that
I have (without having to become a programmer to do that).
Many thanks.
Comment 26 martinkozak 2006-01-27 19:42:15 UTC

We have the exactly same report from Windows XP Proffesional, 
680m145 and Thunderbird 1.0.7 and we also noticed a lot of reports from other 
similar configurations with this problem too. 

According our users, there isn't problem under Linux now, only under Windows. 
Would be well to change OS from 'All' to 'Windows XP' and REOPEN this issue.



Martin Kozák
(CS User Support Leader)