Issue 22758 - Title lines are sorted as data
Summary: Title lines are sorted as data
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial with 7 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: usability
: 16760 54748 80776 (view as issue list)
Depends on:
Blocks: 72764 15522
  Show dependency tree
 
Reported: 2003-11-23 16:07 UTC by serge.le_louarne
Modified: 2013-08-07 15:14 UTC (History)
7 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example of sort with Excel(tm) and OOo Calc (11.92 KB, application/octet-stream)
2003-11-23 16:08 UTC, serge.le_louarne
no flags Details
The patch file is about i22758#-v1. (1.12 KB, text/plain)
2008-10-13 10:01 UTC, yonggang.mao
no flags Details
TestCaseSpecification (9.59 KB, text/html)
2008-12-10 20:25 UTC, oc
no flags Details
For the records: testcase for this issue (122.15 KB, application/pdf)
2008-12-28 17:32 UTC, Stefan Weigel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description serge.le_louarne 2003-11-23 16:07:26 UTC
In Calc, the title line is sorted as data.
See the joined document. It contain an example with Calc ans the result of the
same with Excel(tm)
Comment 1 serge.le_louarne 2003-11-23 16:08:17 UTC
Created attachment 11485 [details]
Example of sort with Excel(tm) and OOo Calc
Comment 2 frank 2003-11-24 09:45:19 UTC
Hi Bettina,

one Enhancement request for you.

Frank
Comment 3 bettina.haberer 2003-11-26 17:01:50 UTC
Hello Niklas, competitor compares the datatype (numeric,
alphabethical, alphanumerical) of the title lines with the datatypes
of the cells, which have to be sorted. If the datatypes are unequal,
the title lines are not sorted, instead they keep title lines.
Please give approval for this evaluated OO.o 2.0 flagged issue. 
If you confirm with the target OO.o 2.0, then please keep it on your
owner (or the owner of the concerning developer) for implementation.
In case you want this issue for 'OOo Later', then please reset the
target milestone. If you decline the issue finally, please set the
resolution to 'Wontfix' (but do not close). In case of 'OOo Later' or
'Wontfix' please reset it on Bettina's owner. Thank you.
Comment 4 bettina.haberer 2003-12-10 17:59:48 UTC
*** Issue 16760 has been marked as a duplicate of this issue. ***
Comment 5 niklas.nebel 2004-01-26 11:24:13 UTC
This is not on the list of features that we're going to do for 2.0. We need to
focus on the enhancements from the PCD document.
Comment 6 pagalmes.lists 2007-07-28 19:01:16 UTC
duplicate with issue 54748 ?
Comment 7 Regina Henschel 2007-08-17 16:02:54 UTC
*** Issue 80776 has been marked as a duplicate of this issue. ***
Comment 8 niklas.nebel 2008-09-19 19:10:04 UTC
*** Issue 54748 has been marked as a duplicate of this issue. ***
Comment 9 yonggang.mao 2008-10-13 03:45:52 UTC
Accepted
Comment 10 yonggang.mao 2008-10-13 03:46:35 UTC
Started
Comment 11 Stefan Weigel 2008-10-13 06:03:54 UTC
Is there a specification for sorting with Calc? Can someone point me to it? If
there is no specification, may I suggest to create one before coding?

For automatic recognition of title lines I would suggest to compare the
data types between first row (text in every column) and the following rows (not
text at least in one column). If all cells of the list, header and data rows,
contain nothing but text, Calc should recognize different formatting in the
first row.


Comment 12 yonggang.mao 2008-10-13 10:01:20 UTC
Created attachment 57135 [details]
The patch file is about i22758#-v1.
Comment 13 niklas.nebel 2008-10-27 20:14:11 UTC
taking the issue
Comment 14 niklas.nebel 2008-10-27 20:15:05 UTC
I added the patch to CWS "calc47".
Comment 15 niklas.nebel 2008-12-04 15:44:17 UTC
Reassigning to QA for verification
Comment 16 oc 2008-12-10 20:25:13 UTC
Created attachment 58694 [details]
TestCaseSpecification
Comment 17 oc 2008-12-10 20:25:49 UTC
verified in internal build cws_calc47
Comment 18 Stefan Weigel 2008-12-11 09:37:13 UTC
Proposal for an extended TestCaseSpecification:
http://wiki.services.openoffice.org/wiki/User:Stefanw/Werkstatt/Testcases_Sorting#Sortingbuttons_detect_columnheaders
Comment 19 Stefan Weigel 2008-12-28 17:26:16 UTC
verified in DEV300_m38.

Thanks, good job!
Comment 20 Stefan Weigel 2008-12-28 17:32:40 UTC
Created attachment 59038 [details]
For the records: testcase for this issue
Comment 21 Stefan Weigel 2008-12-28 17:34:08 UTC
verified, fixed --> closed.
Comment 22 niklas.nebel 2009-01-22 17:57:35 UTC
Note: There's a bit of miscommunication here. What the change in calc47 does is
what's mentioned in the feature announcement: The buttons use the same,
unchanged "header" logic as the dialog, which doesn't look at attributes.

Adding something like sweigel's suggestion sounds useful, but if we want that,
we'll have to do it in a later version.
Comment 23 burgrettici 2010-11-10 16:37:09 UTC
Created attachment 73239